SanDisk Ultra MicroSD card Locked

I have the following problem, my 400GB SanDisk Ultra SD seems to be locked and cannot write, delete any files nor format the card.

  1. I’ve tried various types of SD Card adapters and various USB ports.
  2. I am able to write to other SD cards, so it’s not a port / virus / software / compatability problem.
  3. The physical “lock” is in the unlocked position.
  4. The card is not corrupted since I can still read the existing data.
  5. I’ve tried to unlock the SD card using CMD commands, Regedit, and all the other software “hacks” I can find on Google.
  6. I’ve tried using other software to format it, but they do not work.
  7. I’ve tried using a different device (Camera) to format it, but it still doesn’t work.

Is there anything I can do to recover the use of my SD card?
Is this even covered under the warranty?

P.S. While it’s not a particular big SD card, it still cost me about $100+ so I really do not want to throw it away after using it for less than 2 years.