Screen lights up but completely white

Today, after my daughter charged her Sansaconnect overnight, when she turned it on, there was only a white screen.  Anyone else had this problem and what is the solution.  We tried to do a recovery but no luck. 

Thanks for any help. 

Hold down the power button for at least 20 seconds, then let it go.  The Connect should restart on its own.  If it doesn’t, you didn’t hold down the power button long enough.

If it keeps coming up with a white screen after you do this, you probably have a defective unit.

Yes. I haven’t seen this problem since the original firmware and it was rare.

When you state you tried recovery, I’m going to assume you couldn’t get it to go into recovery mode.

You do need to start from full power OFF to get recovery, so Promised Planet advice is good.

Hold the power button for 8-10 seconds and the unit should power OFF.

Then place unit in Recovery Mode and run the Recovery Tool.

Recovery Mode will update the firmware to the latest which should resolve the problem.

If problem persists after recovery, you should return the unit.