SasnDisk Ultra USB3 128Gb reports wrong serial number

I use a proprietary software that requires the usb stick to report a sn.

I had a previous one that worked fine until it died.

My new stick won’t work with the program.  Everything else is fine format insert ping etc.
Other sticks work fine.

When I run ChipGenius it reposts a very long sn  010103EE8751C2ABD0F35B8C300DEBBA0F35502DADEB4BDDEFD3861D3409DDF9C36900000000000000000000782BAA0D00935A00815581076AA607F9  instead of the correct number on the case.

it was purchased from a reputable supplier.

Any ideas?  Thanks

Return it to the reputable supplier and get a replacement.

1 Like


I have raised this with Sandisk to see if this is the new normal before going back to the store.
121 charicters instead of 20 is not right but I dont want to open packets trying to find out.

Unfortunatly Sandisk support cant see the issue.

I even sent them proof that Windows also reports a 121 charicter serial number.
I asked then to tell me how long the sn should be,  they declined.

I asned them how should I check the sn they declined.

Verry disapointed in the support they offered. 


Dear Gregory,

We appreciate your continued response. I understand that you are receiving a different serial number of the device while checking on the properties of drive. However, Please allow me to inform you that the serial number mentioned in device properties is a hardware serial number or service tag of the hardware which is unique by nature.

And the serial number mentioned on the back of the drive can be common by batch manufactured. The drive’s serial number is use to authenticate the drive.

Also, as you are getting a whole different serial number in ChipGenius software, I will recommend you to get in touch with the ChipGenius support team so that they can assist you better in this case.

Thank you for choosing SanDisk® Products!

Best regards,

Logan R.

SanDisk® Global Customer Care"

I agree with their ChipGenius suggestion.

I also don’t see the words “Serial Number” in the image, rather it shows Device Instant Path.