SansaClip+4GB cannot be authorized for Rhapsody

I use Rhapsody Premier and just got a replacement of a defective SansaClip+4GB that I’m trying to authorize on Rhapsody to transfer music tracks.  I’ve had no problems authorizing two prior SansaClips but with this one I can’t get anything to open that will allow me to authorize this new one.

I used the device compatability report on the Rhapsody page and got information that my device is not currently configued to

use with Rhapsody Premier but that the settings on the Clip could be changed to allow this.  Of course, there was no

information given about how to do this.  I’ve used the Sansa Update and also reformatted the device.  I’ve sent Rhapsody an email about this but am hoping to get some help here.

Anyone with any thoughts on this?

Respectfully submitted.

Try going to Settings/System Settings/USB Mode and selecting MTP.  Can’t hurt.

1 Like

Black-Rectangle - You sure lived up to your Guru status on that one.  It worked!

help my new sansa doesnt have a USB mode under system settings???

It should be there.  If not, there’s been a glitch–you might want to manually reapply the lastest firmware (see the firmware sticky thread at the top of this forum).

There are lots of Sansa now that are all called Clip. I think the Clip Sport no longer has MTP mode so there is no USB mode switch.

That means it’s automatically in MSC mode. You should contact Rhapsody customer service.

1 Like

I have spent 3 hours on the phone with Rhapsody on this issue.  They say it is a Sandisk issue.  Sandisk immediately blew me off saying Sansa devices are not supported by Rhapsody 6.  Why did the Rhapsody tech spend so much time knowing I had a Sansa Clip+?  The barely speaking English boffin @ Sandisk said I had to use Rhapsody 4.  I tried to tell this moron that you cannot download version 4 anymore and she just said you must use Rhadsody 4.  I am going to call the barely speaking English person at Rhapsody, who at least tried to help, agin tomorrow.  I just hate these people.

It is a problem with Rhapsody 6. Get Rhapsody on the phone and ask them for Rhapsody 4. Unfortunately it seems Rhapsody has done an all too thorough job of making Rhapsody 4 disappear but maybe the company itself can get it to you somehow.

Otherwise it’s time to demand a refund on the subscription fee.