Sansa Updater fails

I connect my Sansa Clip+ with USB cable, run the updater and it can’t finish the update. Screenshot is above.

Additional information:

PC/Windows 7 Home Premium


Recently installed Rockbox and tried to uninstall. In order to uninstall, I was uninstalling Rockbox without bootloader which Rockbox Utility couldn’t remove. Rockbox Utility said I should run a regular firmware update to do so. I tried but Sansa Updater wasn’t recognizing player. So I searched the manuals and forums, then tried to copy  firmware file into player and then start the player with left button+power button. At first, I managed to boot with original firmware and made settings, but opened with Rockbox logo again. So I tried it again and I can use through original firmware now. And the updater recognizes it. But gives the error shown above.

Also, wasn’t there a permanent program of Sansa Updater? Current downloadable version is like a portable application. Maybe “Sansa Dispatcher” was the permanent one?

The dispatcher is part of the updater. The application checks for a connected Sansa, checks the firmware level, and checks if any updates are available (including for the updater itslf).  Have you tried the “run as administrator” option in Windows?


Or simply skip the Updater entirely–there is no real need for it, and it uses computer’a system resources. If you need the latest player firmware or the manual, there are forum sticky threads for those at the top of the forums. And, it’s very easy to apply the firmware manually–instructions are in the threads. :slight_smile: