Sansa Player given as gift (used) Not showing up on My Computer or Windows Media Player HELP!

So, of course, i’m a bit of a noob when it comes to computer management. And electronics… Anyway. I was recently given a sansaclip player as a gift. Nothing fancy, just a used player, just the player itself. Music already on it. Plays well, charges well, lights up and everything when plugged into a USB adapter, but it doesn’t show up on My Computer or on anything else, for that matter. Kind of an issue if i want to add more music.

I skimmed some of the FAQs and such, but i’m pretty much lazy and just kind of want a step by step response I suppose…

E-mail: J.stenton@live.com

Messenger: fallenangellifeanddeath@hotmail.com

Either contact works, or just a response here.

Thanks!

What’s your operating system?  Do you meet the Clip’s requirements stated in the manual (see the Clip specifications sticky thread above)?

Can you connect in USB “MSC” mode (which is easier as to the requirements it has)?  On the Clip, go to Settings, USB, and choose MSC.  If you don’t have that option, your Clip has an earlier firmware (and should be upated); you can force an MSC mode connection by turning the Clip off, putting it into hold (on switch all the way down), and then hold the center button down as you connect the Clip and USB cable to your computer.

If i’m correct in your meaning, then Windows XP something. Requirements are all met, I believe unless I’m not understanding something, which is a possibility. And USB is not a part of the settings (how would I go about updating it or by update do you mean go buy a new one?) and as for forcing the MSC, should something pop up…or…what? Do I keep the center button held until soething happens, and if so, what?

  1. Turn Clip off

  2. Move switch on left side of Clip down to “Hold” position

  3. Press-and-hold down the center button (in the middle of the circle) while plugging your Clip into USB

  4. See if your Clip shows up under “My Computer”

Then we’ll go from there.

As PromisedPlanet said; see if your Clip then appears as a drive under My Computer on your computer.

If you don’t currently have a “USB” category listed under Settings on your Clip, that means that the firmware on your Clip is a much earlier version; there have been improvements since then.  If PromisedPlanet’s method above allows you to access the Clip from your computer, you then can update the Clip’s firmware (that is, the software that tells the Clip how to function) by going to the “Firmware upgrade” thread at the top of the Clip forum here (I may have the name off a bit) and then following the instructions there to upgrade your Clip’s firmware.  This will get you the most recent firmware for the Clip, with all of its improvements over time, which includes the ability to go to Settings/USB on the Clip and set that to MSC, which will allow your Clip to connect to your computer automatically, without following PromisedPlanet’s steps in the future (in the end, PromisedPlanet’s steps do what the current firmware’s setting of USB to MSC does automatically).

As a general matter, the Clip can connect to your computer using 2 different computer protocols, “MSC” or “MTP”.  Of the 2, the MSC protocol is more universal and sometimes will allow connections where the MTP protocol will not.  PromisedPlanet’s method, and setting the firmware (after you upgrade your firmware, as noted above) under Settings/USB to MSC, forces the Clip to try the “easier” connection method (MSC), which sometimes will work when the other protocol connection method, MTP, will not.  The MSC connection will get you most of what the MTP connection method will, with one major exception:  as a general matter, you cannot play files protected by digital rights management (DRM), such as Rhapsody subscription music, if the files were transferred to your Clip when the Clip was connected to your computer with an MSC connection–you need an MTP connection for that.  But if you don’t play DRM files, that’s not an issue.

Sorry if this is confusing; just take all of this step-by-step.

Alright. It did not show up under My Computer.

  1. Try using the same USB cable and follow the same procedure on a different computer.

1a) If it doesn’t work, try a different cable.

1b) If it does work, try different USB ports on your computer.

  1. Report back to us.

Alright, as soon as I can use another computer, i’ll do that. Unti lthen and I can report back with anything, thanks for the help thus far.

Hi! Thanks for your assistance. I was using the Sansa Clip with no problems, on Windows XP and Ubuntu until I had to reformat. I am now running Windows SP3. My Sansa Clip is not recognized in MTP mode, and I´ve tried the MSC mode, but then I can’t access all the files I had previously uploaded on the sansa. I’ve tried many of the solutions offered in the Sansa forums, but the bottom line is that when it appears in device manager it has the exclamation mark beside it, and as I have tried to uninstall and reinstall I have gotten three different errors, code 28, a Code 10 if I try to install it as a USB device and a “not able to install due  to INF”. (all these messages are in Spanish, the language of my operating system, so sorry if they don’t translate exactly). I have installed Windows Media Player 11, unistalled it and reinstalled it to no avail.

please help. I switched from iPod to SansaClip and had been loving the experience so far, but this is certainly letting me down :confused:

thanks!

Although it’d be nice if you could resolve your MTP problems, is it really important to have MTP?  Do you have subscription music loaded on your Clip, or do you plan to load subscription music?

Two things:

  1. if you put files on the device in MTP mode and switch to MSC mode, the files will still be there, but you may not be able to see them. In which case, just format the device and re-sync the files.

  2. from my experience on Vista SP2, if it is in MSC mode, it will not show up in the content pane of the “my computer” window - you know, the right side. It will only show up in the tree view on the left.

One anecdote: I’ve had weird problems with my device while changing settings, like having it say there’s not enough memory and it shuts off. The only way to fix it was to right click on it in the tree pane and choose format. After a quick format, it was fine again.