Sansa m240 MTP Device install problem!!!

Hello Forum!!

I have a Sansa m240 and I can´t use it in MTP Mode. Everytime I plugged in the player, the PC recognize it as an MTP Device but the installation process stops before it finished and tells me “The device may not work properly”. In other words, the installation process never complete, and the MTP Device is never fully installed. Of course WMP11 doesn´t recognize the device, so I can´t do much. It works perfectly in MSC mode. I have WinXP SP2 with WMP11, the wmp11 came with the OS, so I never had wmp10 installed, just in case it has something to do with the MTP.

What I can do??

not to be a stick in the mud, but unless you plan on using subscription services or playlist, you dont really need MTP.

Something worth a shot is to add the device manually through control panel. You can select add hardware and follow the on screen instructions.

Yes, I know what you mean, but I would like to create playlist, for instance. I tried to install the device manually, from Device Manager, from Control Panel, I have tried a lot of things!!, but none worked for me!!!

Help pleaseee!!!

Hey I am in the same boat here. I cannot sync a playlist from WMP11 or realplayer. If I try to the device stops sync after the first song. I can go into windows explorer and manually load them 1 by 1, but this seems a bit silly to me. Even when I do the 1 at a time load, the file transfer never really completes. I have to tell it to cancel. The track does go to the sansa though. Mine is in the MTP mode whenever I link it up to the computer through the USB. I don’t know what the other modes are, the manual was a little vague. Let me know if you find something out. Thanks

hey everyone,

i have an m240 and it worked fine with my win xp pro until i reinstalled my windows then i encountered the “service installation in this inf” error. i just did some searching and i found another forum with someone with the same error with a different player brand. they posted this link:

i downloaded the file, installed it, updated the m240 driver in the device manager, and the ‘mtp device’ installed correctly.

The filename is “Microsoft_User-Mode_Driver_Framework_Install-v.1.0-WinXP.exe”.

hope this helps.

Thanks tomjr but I have tried this already, and when I installed the Microsoft_User-Mode_Driver_Framework_Install-v.1.0-WinXP.exe the installation program said it can´t continue ´cause “An equivalent or newer version of UMDF is already installed on this system” and keep having the same problems with my MTP Device.


Somehow I managed to get the device installed, and now I have an MTP Device in my Device Manager, but Windows Media Player or any other software, not recognize the player, they say “connect the player”. Now when I look in the Driver Details in the Device Manager only the wpdusb.sys is loaded and the service “Windows Driver Foundation - User-mode Driver Framework” can´t start, I received the following error message “Could not start the Windows Driver Foundation - User-mode Driver Framework service on Local Computer. Error 1053: The service did not respond to the start or control request in a timely fashion”.


What I can do?, I know I need this service started to load the wudfrd.sys, which is needed for the device to working properly, any ideas pleaseeeeeeeee??

I found this posting:

      I hope I can help. I have a Sansa m240 so it should be the same functions. To get to MSC mode, turn on the player. After it completes the boot cycle hit your _ Menu button. (The same button as the power button) It will take you a new menu. Scroll down till you see **Settings. ** Select that and you are in that menu. Scroll and look for **USB. ** There you can change your settings. You will see **MSC** and **MTP** or you may see **MSC** and **Auto Detect**. Click on **MSC_** and you are done. You can either reboot your palyer or continually hit the music back or previous button to get back to your music list.

   When you want to get back to MTP mode, do the same and click on MTP or Auto Detect.

I hope this helps you. If you haveadditional problems, you can always go online to Sandisk and call or submit an Support Request. They can be helpful too.

Thanks a lot buddy!!
It has worked perfectly for me. Just downloaded this file and installed the MTP device from the device manager.



My Sansa is dead and not playing any songs. When I connect to my laptop it says “Found New hardware MTP Device” and not proceeding.

I tried installing  “Microsoft_User-Mode_Driver_Framework_Install-v1.0-WinXP” but is says “already installed” but of no use.

awaiting for your suggestions



in device manager is it showing up as an unknown device? if so look at the properties and let us know what the error code is.

also has this device worked normally on that pc in the past?