Sansa Fuze Skip Song

1 months ago I purchased a Sansa Fuze 4GB and I really enjoyed it.  In that first month I transferred music from Microsoft Media Player to the Fuze with no problems and I also played music with no problems, at least I don’t see any problems.  Everything seemed to be working great until last night when I installed the new firmware. 


I installed the new firmware using Sansa Firmware Installation application. After installing the new firmware, I had to resync my library.  I noticed after the resync when I played music, many songs on the fuze would be skipped.  For example, I would play song ABC and after song ABC was over, I would see the image for song DEF, but the song DEF would not play and the Fuze would skip to the next song HIG.  If I tried to navigate backwards to the song (DEF), which was originally skipped, it would be displayed, but the Fuze would skip to the next song HIG.


If I tried to navigate directly to the skipped song through Fuze’s interface, the song would not play.  Artist ZYX had multiple songs in their folder.  If I selected to play all the songs for that specific artist, the Fuze would skip infinitely without playing any music.


Also, after I upgraded the firmware, I noticed the all my music was removed from the Fuze and my GoList was empty.


Does anyone have any recommendation on how to resolve these problems? 



I tried resting the Fuze by sliding the spring-loaded power switch on the side up as if you were turning on the device, but hold it in the upper position for 20-30 seconds, as described here, but it did not work.




Message Edited by BarDev on 08-02-2010 08:09 AM

Well, that shouldn’t happen.

Did the Fuze music not show up on the Fuze, or on your computer? Because the update may have switched the USB Mode. There are two, MSC and MTP. Your computer can only see music transferred via one mode at a time, while the Fuze sees all. If your computer didn’t see the music, it could be visible in the other mode. Settings/System Settings/USB Mode.

But if it was gone from the Fuze, well…

A firmware update will wipe out the Go list, because those are assumed to be temporary, but it should not affect your songs. 

First try this: connect the Fuze to your computer and see if you can play the songs on the Fuze from the computer.

If you can, then the songs are still working and maybe something went wrong with the firmware update. Go to the firmware update thread and do the manual update–it’s a pretty simple procedure.

(You can’t use the Sansa Updater again because all it does is look for the version number, and it will see a current version.)

If the songs don’t work from your computer, get them off the Fuze. The easiest way is to disconnect and go to Settings/System Settings/Format and do the format. That will get rid of all the music, so make sure beforehand that you have other copies. 

Then try synching again, and see if they work better this time. If not, then try the manual firmware update. 

And if you’re still having trouble, call 1-866-SANDISK. 

Message Edited by Black-Rectangle on 08-02-2010 01:26 PM

Thanks for the suggestions.

I connected the Fuze to my computer and was able to play a song on my computer from the Fuze that was previous skipped over.

I formatted the drive.  After formatting the drive, I resynced the Fuze to Media Player.  Now everything seems to be working.

Thanks for the help.