Sansa Fuze+ - Frozen Loading Screen


I’m having a few issues with my new Sansa Fuze+ and wonder if anyone has suggestions. I’ve searched the forums and have identified probable causes.

Firstly, the device has the latest firmware as of today. The device has also been formatted using the option in the settings. When there are no music files on the device it loads without a problem.

After copying music files to the device (oggs in the Music directory) using file explorer in Win7 then safely removing the device and finally unplugging the cable, the device restarts and gets to the loading screen with the cycling grey petals. After a minute or so the petals stop cycling (static image) and the device remains in this state until it is hard reset (holding down the power button for 20seconds). I’ve tried leaving it for a good while to see if it was still working in the background, but to no avail.

I’m aware that one of the possible causes is problem tag data. To sort through 4GB of music files seems a slow trial and error process. So, is there a logfile created on the device that I can look at over USB to determine the exact cause of it freezing if there is a problem ogg file? 



no log files are created. it is likely one or more of the OGG files. i have seen a few reports where some OGG or flac can cause similar issues. only thing to do will be going through the files and see which ones are creating the issue. 

ok thanks.

I worked through the ogg files and narrowed it down to one album. Are there any particular characters that could occur in a TAG or filename that the fuze+ wouldn’t like? Is it ok with album names or titles that start with 0-9?

Example characters used in the titles and artists and filenames in this particular album: a-z A-Z 0-9 ( ) + ’ - ! ü

Could any of these be an issue?

In case this is useful for debugging, the album in question is: “2 Many DJ’s - As Heard On Radio Soulwax Pt2”. and the track data is pulled from CDDB -



After loading some new music files my Sansa Fuze+ is now stuck at the loading screen and will not do anything else. I can barely get it turned off.

I deleted the new files I had loaded through my computer with no results.

I guess I have to format it, or what?

Try resetting it.

Try retagging thisnalbum with MP3Tag. If that fails, make sure the files are playable on your computer. Also note, ogg files with embeded album art are unsupported. You can still use external jpegs, as long as they are in the same folder as the album.