Sansa Fuze 2GB - black screen when i push a button


First of all I hope that u can excuse my bad English!

Here is the case…

I bought myself a Sansa Fuze 2GB mp3-player. It works well except for one thing.

When I´m trying to scroll in the menu with the “wheel” or whatever it´s called the display goes black.

After a few seconds the display goes back to normal and I can see what´s on the display.

I find it quite annoying, it´s much easier I u can see where u are in the menu:P

So, are there any1 else that have got the same problem?

Sry for my bad English.

Best regards: manutd

Did you try changing the display settings?  The backlight goes off after a specified time.

Well, the problem is when I touch the any button the screen goes black…:neutral_face:

So it´s hard to see where I am in the menu.

I added a clip on youtube so u can see how it looks…

Message Edited by manutd on 07-28-2009 10:38 PM

this is wierd… have you already tried to reload the firmware. you may want to contact sandisk directly so incase that this needs to be replaced, they may do so…

Yeah, I´ve upgraded to the latest firmware but still no change.

I´ll guess that I have to mail/call sandisk to see what they have to say about it.