Sansa Fuse+ - Won't connect to Windows 7 or Puppy Linux Now empty and no music!


I’ve got a Sansa Fuse+ - it’s stopped connecting to the laptop and I stupidly tried formatting and resetting it so now I have an empty MP3 player. Worst thing is I’m currently travelling in South America and am deseperate for music for long bus journeys!

I’ve read the forums and tried a lot of different things.

The symptons are:

  1. it will charge from the wall

  2. when I plug it into a computer it turns on but won’t charge and won’t connect.

I have *already* tried the following:

  1. Holding down the VOL DOWN when I connect it

  2. Long power off hold down

  3. Changing USB Cable

  4. Trying a different computer

  5. Trying linux (Puppy)

  6. Different USB ports.

  7. Changing USB mode MTS etc…

  8. Downloading the firmware updater (it won’t finish the install as it can’t find the player)

Is there anything left to try or should I give up?

Any help much appreciated - please save me from South American bus drivers terrible music!

I’m having this same problem