Sansa Express 2gb not responding

My player has stopped working. I don’t know what triggered it, whether the battery was dead or whatever. I tried to turn in on at some point and all it did was flash the Sandisk logo and then go blank.

What I’ve tried:

  • plugging into computer - no response on computer whatsoever, doesn’t show up as any sort of device. On the player I occasionally get the Sandisk logo, and occasionally a bit of garbeld symbol, then blank again

  • plugging into computer holding volume “-” button, no response

  • soft reset (power button for 20sec) - no response on repeated attempts

  • hard reset (center button + volume “+” button for 20sec) - no response on repeated attempts

  • firmware update - doesn’t work because the computer won’t recognize it!

  • plugging into another computer - starts to be recognized as MTP device, but then hangs, with no device shown in windows. On the player I get the same as before, or nothing at all

  • charging for 2.5 hours… I’ve had it plugged in to the computer (not on standby) for many hours, but have no way of knowing if it’s being charged as there is no response. In any case, there is no response after this time

This will definitely be my last Sansa player, but it’d be nice if it just worked for once. It’s locked up on me before but I somehow got it working, but have no idea how.

Any ideas other than taking it outside and stepping on it?