Sansa express 2GB just died

I have recently bought 2GB Sansa Express. After transferring MP3’s today the player stopped working.

When swithching on just get SanDisk on screen then switches off almost immediately.

Have tried hard reset, didn’t work. When connecting to pc the player now shows as storage device.

Following other threads I assume this is in MSC mode, but I can’t seem to do anything to change it.

When running Sansa updater, message comes up “No updateable sansa product has been recognised”

Not sure what to do next??

Have continued to try and resolve. Now when plugging in sansa express get a message of found new hardware MTP device on a continual loop at approx 2-3 sec intervals.

After many attempts now working OK

Can you tell me how you solved this problem. As I seem to have the same problem



Trying to reload firmware multiple times it helps, also trying to insert memory card in the player. :wink:

mine just died too. the blue circle light remains on and cannot turn it off.

Generally speaking mine can act strangely when the charge is low