Sansa Express not working at all

I have a new sansa express that worked when I originally opened it.  I was able to transfer some audio files onto it and it played them fine.  I plugged it into the usb on my computer (Mac OS 10.3.9) so that it could fully charge for at least 2 hours (as per the instructions for first time charging).  The OS system recognized it and displayed its icon on the desktop.  When I returned to the computer a couple of hours later, the icon was gone from my desktop and the LED screen on the player was blank.  I attempted to turn it back on, but nothing happened.  Tried to hard reset it too.  Still nothing.

I should also note that the computer had gone to “sleep” while it was plugged into the usb port.  Do not know if this had any bearing on it.  Has anyone else encountered this problem?

Thanks.

Well, I just had the exact problem on a PC running the Vista OS and this is my third replacement device!  Computer went to sleep and now, a previously working Sandisk Express is dead.  It had about 85% of the battery left.  I have been using it for a few weeks, worked fine. 

Here’s the deal, this is my third replacement from Sandisk.  The others started acting up in a similar way, slight difference: the logo would show up, then the device went dead.

I’m really fed up.

You can call customer support.  They’ll put you through a few dumbass procedures that are already listed here on the site, then put you in line for a replacement.  But if you just purchased the thing today?  Take it back to the store.  I can’t recommend this product.  I love the looks and the recording feature, but I’m on my third one in less than a year.  Try another one.

Thanks for your advice.  Fortunately, this did not cost me anything.  One of my daughters won it.  I have an e-mail into customer support and will take it from there.  From what I am seeing on this site, these players are pretty unreliable.