Sansa e280 not connecting to pc


I’ve trawled through the forum but I can’t find an answer… my e280 is a version 2. It will not connect to any pc (even though it worked fine 2 weeks ago). I have tried every USB port and tried two leads. In the Settings, it does not have a USB option so I cannot change it to either MTP to MSC. I have reset factory settings and formatted it but neither made a difference.

(Also, when I charge it via plug it often freezes and I have to reset it and its time-keeping is terrible - it both adds time and looses time so I’m always having to re-set it.)

Help please?

Sorry for double post - couldn’t find an edit button.

I meant to add the following but forgot - v03.01.11E

You must have early firmware. Go to the Firmware Upgrade sticky for v2, near the top of the first forum page,  and follow the manual upgrade instructions.

Thanks for that but I can’t get the pc to recognise the player. The player itself only shows that its charging from the usb port. I’ve tried looking for it in device manager and its not there. How can I update the firmware if I can’t connect the player?

I’ve also tried looking for a driver but can’t find anywhere.

You must manually force MSC mode.  Once connected in MSC, you can then transfer firmware version 03.01.16, and you will then have the USB Mode option in settings.

In this thread, for firmware 03.01.16, follow the steps at the beginning of the thread to manually enable MSC mode.  You can then transfer the firmware according to the steps listed.

With firmware 03.01.11, the e200 series v2 was initialy released without the USB mode option.  This was added in later firmware revisions.

MTP mode is needed for protected media with DRM, like Napster, Rhapsody, Audible, and Overdrive books.  Once your firmware is updated, MTP can be repaired by updating to Windows Media Player 10 or later, or via the Device Manager, if Windows Media Player is up-to-date.


Thank you but the manual force into MSC doesn’t work. I’m at a loss as to what else I can do.

Are you sure you are starting with the unit OFF and the Hold button on?

Yep! Unit is off, hold is on and I hold down the rewind button and turn it on. I keep the |<< button held down, waiting and hoping for a connection but neither the pc nor the unit seem to recognise the connection.

I can load music/books onto an SD card and listen that way but I want to be able to connect and use playlists etc like I could 2 weeks ago. Also now the screen keeps wigging out. I either get lines down it or it glares white and almost completely obscures the picture.

Is my player dead? :cry:

For info… I contacted Sansa tech help and they said my player was dead and replaced it with a Fuze.