my sansa e250 does not have usb mode on its setting menu

my sansa e250 does not have usb mode on its setting menu… i’ve tried to look for usb mode on all menus but i can’t find it… and the computer cannot recognize the device… it also stops charging the battery even if the device displays it is connected to the computer…  how can i fix this?

My e280 v2 didn’t have it either when I received it 10 days ago.

But I downloaded the Firmware Installer and immediately upgraded to the latest firmware 03.01.16.

Now there are three USB modes in the Settings Menu: Auto, MTP, and MSC.

I found yesterday that I do not even need MSC. I was able to read from and write to both the Sansa’s Internal Memory and the sd card in the MTP mode (portable device). Both folders appeared under My Computer. If I switched to MSC mode, I could not see any of the music folders under Internal Memory because they were transferred via MTP. But I was certainly able to see the music folders transferred to my external micro sd card via MSC in the MTP mode.

The early firmware version 3.01.11 had no USB Mode selection option, and was an MTP-only release.

As you might have discovered, having the MSC option in “settings” is quite convenient.  For the early v2 units, the only option was to manually establish an MSC connection by switching the HOLD/LOCK switch on, and hold the << button down during connection.

One can easily drag and drop in MTP mode as long as the host PC has Windows Media Player 10/11 as well, though the protocol in MTP mode isn’t exactly the same, it functions well.  The big advantage is being able to see everything in Windows Explorer, if you have DRM files with your collection.

I am very glad that SanDisk gave us the option, rather than the competition’s “what you see is what you get” version. 

Bob :smileyvery-happy:

yeah… i’m already done loading the firmware in my device… my problem now is that my device’s battery is low… and the firmware upgrade cannot be executed… and my device stops charging… and the icon shows that the battery has only half of its full charge… u know how to fix this?

If your device isn’t being recognized in MTP mode, all you have to do is force an MSC connection:

Turn off the sansa v2.

Flip the LOCK / HOLD switch to the right (orange showing)

Hold down the << button while connecting.  An MSC connection should be established within 15 seconds or so, at the most, if the PC’s never sen the device in this mode.  Keep the << button depressed until it shows “connected” on the display.

At this point, you should see the little lightning bolt.

Bob :smileyvery-happy: 

Make sure your sansa is updated. You can update it at:

Good Luck!