"SANSA CLIPP" gPodder won't recognise the device...

I’ve been using my old Clip v2 with Linux mint and gPodder for quite some time now. I’ve just been given a Clip+ which Mint recognises as “sansa clipp”. But gpodder doesn’t recognise it.

I’ve tried changing the Edit Config preferences in gPodder from ‘/media/CLIP/PODCASTS’ to ‘/media/SANSA CLIPP/PODCASTS’ (I’ve also tried speech marks) but that doesn’t work.

I’ve tried using gParted to re-label the device to a name without the space, but gparted throws up an error at the attempt.

How can I either get gPodder to recognise the device?


Make sure your clip is set to MSC mode not Auto or MTP.  You can find this in Settings > USB Mode.