You dont need a driver. There are two USB modes on the Clip+, MTP and MSC (Settings > System Settings > USB). If you connected the Sansa while on MTP, it wont be recognized by your PC unless you have Windows Media Player version 10 or above. Try switching the mode to MSC and see if it will be recognized.

I am all of a sudden having problems with my Sansa Clip Plus.  Upon plugging it intpo my Windows 7, I get a boop boop sound that something was attached, and then a pop up balloon comes up saying " installing device driver software", after a moment of this a balloon screen says “Device Driver Software not installed”.  Upon clicking this balloon for help a popup screen says … please consult with your device manufacturer for assistance getting this device installed.  There is also" MTP USB Device" with a “Failed” after it.  I have seen some notations for a second mode MSC, but I can’t seem to find it, and wouldn’t have monkeyed around with any settings (I am kind of green with computers).

When I plug in the Sansa, the screen says “connected”, but if I try to pull it up on the “my computer” it does not show.   If I pull the Sansa out, I get the boop boop on the computer indicating something was removed, and the Sansa screen just continues to say “connected”  (The battery bar shows a full charge). 

If I hold the start button down for 15 seconds the Sansa will shut off.  If I take the now dormant Sansa and plug it back into the computer, the Sansa screen lights back up, and now reads “writing”.  The Windows 7 balloon comes up saying something about installing the driver, and then saying the driver was not installed.  If I click on the not installed balloon, it gives me the popup saying contact the manufacturer.  If I pull the Sansa now, the screen will continue to say “writing” unless I manually tuirn it off.  I am going to leave it connected overnight in case it really is doing something, albeit incredilbly slowly.

The Sansa updater seems to say there are no updates.  I am not sure of the Windows Media Player version, but it says it was created in 2009 and was last updated in March of this year. 

Initial problem was when I was trying to add music, and one of the files from the Windows Media Player had about 32 songs on it.  The fifth song apparently had some kind of a problem, as the Sansa would freeze up in the middle of the tune, and I couldn’t get it to do anything unless I did the 15 second hold down and restart routine.  If I tried to play the sixth song from the album, it would skip down to the eighth song, and then play the rest normally.  I figured something must have gone wrong with the drag and drop of the album, so I tried deleting the album to try dragging and dropping again and that’s when the problems started, or at least became noticeable.  I can’t think I could have deleted a driver, as I wouldn’t know where to look for it . Although I  thought I had simply deleted the errant album, when I tried checking to see if any music would play, I could get it to do that, though the errant album still showed present, but none of the tunes on that album would play (the screen just went down to the 32nd tune and did nothing).

There has to be a driver for the Clip somehow, otherwise Windows 7 wouldn’t be looking for it, I should think.  Why SanDisk doesn’t simply make a driver available for reinsertion seems a mystery as that ought to be the fastest fix.

With the Sansa disconnected from the computer  I tried plugging in the headphones and was able to hear music, so I think it works, but without being able to connect to the computer again, I don’t think I can add or delete music, which kind of limits future use.

Any ideas are appreciated.


Go to Settings/System Settings/USB Mode.

There are 3 settings: MSC, MTP and Auto. 

Auto switches between MTP and MSC.

If the Sansa detects Windows Media Player 10 or above on your computer, Auto is supposed to send it to MTP.

If not (or if it’s Linux or Apple), Auto is supposed to go to MSC. Obviously yours is being annoying. 

So try both fixed USB modes. If you like WMPlayer try MTP first. If that’s problematic use MSC.

The drives for MTP mode are included in  Windows Media Player and the driver for MSC mode is the standard basic lowest common denominator USB driver. That’s why Sandisc doesn’t add drivers–it shouldn’t need any. 

MSC is mass storage class–basically your computer sees the Sansa as two drives, SANSA CLIP and REMOVABLE DISC (the card slot). You can drag-and-drop to either one.

Many of us here prefer MSC because it is more straightforward than MTP, which treats the Sansa as a “Virtual media device” (whatever the heck that is) . But use whatever works for you. 

Some additional items:  I had notes from a problem I had about two years ago, which suggested that I unplug the Sansa, turn it off, and plug it back in, holding down the center button.  Doing that gets me to the screen doing a more normal routine of alternating SanDisk logo, “connected” with arrows blinking and the battery icon blinking just a tad.  The Computer tree now shows Sansa on Removable port “I” and the eject button on the toolbar now shows how I can safely eject the Sansa - all good stuff. 

However, when I do eject the Sansa, the screen goes to “Music” icon (I had thought it shut off automatically) when removed from the computer, and when I manually turned it off and pluged it back into the computer, the “searching for driver routine” and “fail to find driver” routines come up and there is no Sandisk button on the toolbar.  Situation is better, but still not resolved.


Holding the button forces MSC mode. Something goofy is going on with your MTP. So try MSC. 

(Incidentally, the Music thing is fine. The Sansa assumes you transferred music via MSC and now you want to listen to it. )

>>>Go to Settings/System Settings/USB Mode.<<<

Sorry to be incredibly dense, but I don’t know how to get to whereever that is.  If I go to control panel, and go to system, I don’t see anything that suggests settings  or USB Mode(s).  If I try typing in Settings at “start search box” I still get to nothing that is obvious for USB.  For the great unwashed out here, getting a Sansa player to play can’t be that involved.  I’d hate to start diddling with things that I don’t know what they are. 

When I tried simply plugging in the Sansa without hitting the middle button, Windows 7 still can’t find the driver, there is no recognition at port “I”, and the Sansa is stuck on “connected” without doing anything more.


Settings is on the Clip.

Click the Home button (upper right) and then the Play button (12 o’clock) up from Music to Settings.

Hit the center button and click down to System Settings.

Center Button gives you the options.

You don’t have to do anything on your computer unless you want to try reinstalling Windows Media Player from , which would possibly fix MTP drivers. But MSC will give you less trouble.

In MSC mode, the computer won’t see stuff you sent over by MTP. (The Clip itself sees everything.)

So the ideal thing to do, though it’s somewhat annoying, is go back to Settings/System Settings and Format the Sansa, which will remove all the files you put on (including the one that made it flip out initially). Then drag-and-drop your music back on via MSC.

Thank You, Black Rectangle, for your help. Sansa is working fine again.  You may have your doubts, but I DO know how to walk and chew gum at the same time, although upon seeing what you were trying to tell me it might have not been apparent.  I guess I figured that because Windows was coming up with the popup boxes, it was a PC issue, when in reality it was a setting ON THE CLIP that needed adjustment.  I am pretty sure I have never played with that auto/MSC option before, so how it got changed is a bit of a mystery.  Also mysterious is the corrupted album I tried to delete.  The titles all still appeared on the Sansa screen, but when I tried to delete them one by one, the screen would zip through them all and stop at the last one.  I have subsequently re-synced the Album to the Sansa, and now it plays fine, track 5 and all.  Thanks again for your guidance.


OK, this is just a guess, but was the problem album ripped on an Apple computer?

When Mac OSX rips an album it makes mp3s (assuming the iTunes defaults have been changed to mp3) and, just for fun, a subfolder called MACOSX with files named  ._01-Song1.mp3, etc.  They start with dot underscore, they are 0kb in size and they are finder files for the Mac’s ever so charming indexing system. Giving them the .mp3 file extension was really a brilliant idea from Apple.

If a folder of those gets transferred to the Sansa, it looks at the mp3 extension and thinks, oh boy, a song. Except there’s no song, so it “plays” through the 0kb of silence and on to the next “song,” zipping through the whole folder.  That might be what happened with your corrupt album.

If you get an album ripped on a Mac, or from an unknown source, always open the folder and see what’s in there. There might be giant cover art (which you can delete after sending the folder over to the Sansa) or the MACOSX subfolder, which you can delete on your computer since Windows will never need it.  DS_Store, another Mac artifact, can also be deleted.

If you updated the firmware, it may have reset to Auto since that’s the default.