Sansa Clip Software installation problem.

I am running Windows xp Media Center.   When I connect to the USB I get the following error. 

“There was a problem installing this hardware MTP device. An error occurred during the installation of this device. The system cannot find the specified file.” 

 I contacted support and we downloaded Microsoft MTP porting kit.  Didn’t work.  After a long session they said the only thing they could do is show me how to connect the Clip as a mass storage device…  This worked to get a few songs in it,  but does not load playlist nor do other features work either.  I just loaded have the latest firmware clip01.01.20a… still gets the same error.   If I connect to my daughters laptop the Clip works perfectly… she is running Vista.  

Can anyone provide a solution to this short of replacing my OS? 

Try formatting your device from the Format function on the player. After that connect in regular MTP mode and check your device manager. If the Clip shows up with a “!” or “?” try uninstalling the device, disconnecting the player and then re-connect the player. If that fails, you should probably call SanDisk back. They should replace it if it’s not operating like it should. Especially if another clip connects. its probably not your computer

Gotta love it, Microsoft overcomplicates everything…first do a simple fix: reboot the PC, and then try connecting the sansa in MTP mode.  Actually, on the device, select under Settings > USB mode> auto detect.

This way, the device will attempt to establish an MTP connection first, before trying MSC.

Open My Computer and see if the sansa is under “Other Devices”, without an assigned drive letter, meaning it’s an audio device in MTP mode.  Post your findings here!

Bob  :smileyvery-happy: