Sansa Clip screen dying + an imprint?

I’ve had a Sansa Clip for nearly 3 months now and about a week ago, I noticed a strange “imprint” behind the screen. Every day, the screen got dimmer and imprint got clearer. I’m pretty sure it’s the sansa clip and monitor icon that appears when you connect the clip to the computer. Anyways, the screen is so dim I can barely see anything. Is there any way to fix this or is my player just about cashed out?

I’ve tried reset, I did the firmware updates as soon as I bought it (July 1, 2010). I only dropped it once while opening the box on the same day (packaging was ripped), but nothing happened to it.

If the OLED screen is progressively dimming, it sounds like it’s dying. No, there’s no way to fix it.

If you bought it new, Sandisk products have a one-year warranty in the US. The warranty may be longer or shorter in other regions. You can call their support number (1-866-SANDISK in the US, I believe) and arrange for a replacement under warranty.

I actually live in Canada and I bought it from TigerDirect, which only has a one month warranty. I guess I’m out of luck. Would downgrading and upgrading help by any chance?

@foolz wrote:

I actually live in Canada and I bought it from TigerDirect, which only has a one month warranty. I guess I’m out of luck. Would downgrading and upgrading help by any chance?


If it was new, it doesn’t matter if you bought it from TigerDirect, the manufacturer’s warranty still applies. If it’s refurbished/recertified, then you’re stuck with TD’s warranty.


Reinstalling the firmware may or may not help (honestly, it probably won’t), but it can’t hurt to try.

Yeah, it is refurbrished. Oh well.

Though, how do I revert to the old firmware and then upgrade it? Just format it?

You don’t need to revert or reformat.  Simply apply the firmware bin file as stated in the firmware upgrade sticky thread  instructions.

No luck with the update. Thing is, the battery sign appears fine. I think there’s a bunch of logos overlapping each other in the background continiously, dimming the screen really bad. Anyone know why?

Part of me assumes that this is a hardware malfunction.  And part of me is curious as to what would happen if you Rockboxed your player (although I only would try that as a last ditch attempt–it could make matters worse, or the player, even, nonfunctional).

I guess I have nothing to lose - I’ll Rockbox it. The blue ring went out too though. Guess it’s just about cashed out.

You might want to leave it charging overnight–sometimes that seems to fix issues.  Also, just leaving the player alone a few days has caused resurrections.

The Rockbox firmware download on their site is down. Any mirrors?

The current build download works fine for me (I just tried it).

Alright, I just tried it and it installed successfully. The problem still exists. Would taking it apart and checking the insides help somehow?

Had the feeling–a hardware issue.  I’ll leave that to the engineers in the room …

I can sort of manage with the speech feature in Rockbox, but it’s really frustrating. Anything?

Edit: I was googling and I found this:

Seems to be the same problem, except nobody tried to help.

More googling revealed this:

Seems to be my problem. Should I try it?

Screen is completely out now, by the way. CAn’t see a thing.

You don’t really have much to lose, right? There are special plastic “tools” designed to spread apart casings if you want to try and find some. That would be better then scarring up the case using a small flat screwdriver to take it apart this guy suggests.

Good luck!

Can I get an example of these “plastic tools” or maybe some places where I can find some? (a reliable and inexpensive Hong Kong source) sells a variety of prying tools kits, rather inexpensively.  Some of the tools resemble guitar picks.