Sansa Clip Plus Format Problem

Hi Friends,

As you see i am new at here. I have a problem with my sansa clip plus. I’ve loaded Rockbox to my clip plus. After a while i have started to get some problems like freezing. when mp3 player freeze you can’t do anything without reset it. I have tried to update it manually and now i can’t open or format it. i have uninstalled Rockbox. I hope there is someone who can help me…

It may have something to do with your files (format, length, source, etc.). Maybe if you gave us some information about them, someone could see or suggest something for you. :wink:

Btw, your Subject title is a bit mis-leading. You might consider editing it to relect your question/problem more accurately.

Firstly thanks for your reply. I have big problems. I am writing from Turkey. Sandisk isn’t selling mp3s officially in my country so i don’t have a option as service. To get to the main point, now i can’t format my mp3 player. I made a mistake as doing format within rockbox my clip plus. After format rockbox files has been deleted naturally. After format i tried to update my clip plus manually. I made it before and i didn’t encountered a problem. But at this time when mp3 player opens,  screen is freezing and it is lasting like this till run out of battery. I put in to computer it but i can’t format. So i decided to do it manually :cry: and deleted all files. Now it is opening and after sansa text sansa symbol seems and staying like this. Please help me. As i mentioned on the top i can’t send to service so i have to do it manually. I am waiting for your responses…

Have you tried the Manual firmware update instructions from this post?