Sansa Clip+ 4GB almost dead...

I have read a lot in different forums and have not yet found a solution to my problem.

My Clip+ had halted and I did the research and resetted it, and was able to save it. Then I tried copying files into the media folder but some folders would copy and others wouldn´t. So I tried, in the Settings menu to do a reset to factory configuration. It asked my my location and when I chose something like america it froze again. I tried another reset holding the power button for 30 seconds and nothing happened.

Now it sometimes turn on but freezes on the sansa flower logo. Windows does not recognize it and when it does I try to format the flash memory (of 30.6MB) but Windows cannot format it. I wanted to replace the firmware but there is no chance. Any thoughts or any solution? I am willing to open it if there is any another way to reset the firmware manually. 

Or should I resign and have a new overpriced paperweight?


perhaps you could try unbricking it using These Methods posted on the Rockbox wiki.

I have the same issue. What did you do to get it connected at least as 30 MB flash?