Sansa clip + corrupt

Hi, I have a one month old 8gb + that has rockbox 3.7.1 on it.

Everything was going fine until today when it crashed.

I have fully charged it but now I have three problems.

If i try to start it with original firmware by holding the left rewind button the player will boot up but just stays on the sansa logo screen and then does nothing after this

If I try to start it with rockbox by holding the + volume button and powering on, the player boots up fine but when in the menu the player (without me touching anything the player) automatically goes down the list until it gets to system. The player does not respond after this.

Also the player is not recognised any more when I plug it into my laptop.

Any help?

Thanks

marco

UPDATE

I have managed to get rockbox to work:smiley:

But, I still can not get sansa to work or the laptop to recognise the player.

Is their away of deleting rockbox within the rockbox setting so that I could return it to amazon with just the sansa firmware on it?

Are you unable to connect the Clip to your computer so as to use the computer to delete the Rockbox files?

Hi and thanks for the reply.

No the laptop does not recognise that I have the sansa plugged into a usb slot, I have tried 3 cables and have tried all my usb ports on the laptop.

Earlier on today the laptop recognised the sansa and I could access the internal memory but now that the battery has recharged it no longer recognises it.

The time function has stopped working in rockbox, each time I turn the player on is stick at 23.03 even if I change the time it doesn’t move, it just stays at the inital time that I set.

Whilst listening to music in rockbox the music cut out and i now have a message on screen saying

*panic*

microSD init failed

:  -3

Will defo be sending back to Amazon now:cry:

You might want to try to force a connection:  with the Clip off, hold the center button down when you connect the Clip to your computer. 

I have held the button down but the laptop says it can’t recognise the usb device as the usb device is unknown.

I am going to run the battery down and see what happens the next time I charge it via the laptop.

Cheers

Great next step–

Right, slowly getting their.

I ran the player for about 8 hours to drain the battery.

When I plug the player in to the laptopand leave it for about 5 minutes, the players connects and starts charging itself, this allows me to access the the internal memory.

I have tried to reinstal the firmware, but once the player turns back on after the firmware upgrade it just sticks on the language settings, ie will not move off the english setting.

Is their anything i can change or delete within the internal memory to hopefully get the sansa player to respond or will I just delete everything?

I take it if I delete everything in here this will get rid of the rockbox settings?

Thanks again.

I might just try starting all over, beginning with a reformat from the Clip settings or via your computer.