Sansa Clip+ no longer recognized as usb drive

The sansa clip player has always been fickle, now no matter what I try it is no longer recognized as an attached usb device on multiple computers , (win 7 and xp), >> tried using different cables , >> resetting to factory settings , >> formatting player , >> scanning for new devices , (win 7), >> disabling and re-enabling usb root hubs , (win 7), >> tried using a microsd class 10 card from my camera to transfer music, ( crashed and blacked screened sansa clip, ie: bricked ), however the player did recover after removing and waiting several minutes.

>> Contemplating buying a micro sd class 4 card to load music, beyond what I have detailed, what is left to do?

Note , when I do plug in the player, it does turn on but defaults to menu screen instead of connecting as usb device, no new attached drive shown on windows 7. No new device shown in devices and printers. What use to work was to power and hold the menu button will booting. This no longer works…

Version: V0102.16A

Tried setting MTP, MCP, auto

What to do next…