Sansa Clip + 8GB not recognized on my PC

I have windows 7 home premium, SP1

Used to have no issues accessing the MP3 player.

Now I can only see the files in windows explorer.  Whenever I try to copy to the Clip, I get either error message:

A device attached to the system is not functioning

~ or ~

The device has either stopped responding or has been disconnected.  Although this device supports audio files, it does not support .MP3 files…

The second message is ludicrous since the Clip is loaded all with MP3s.  Generic message…

I have tried to swith USB modes from auto detect to MTP and MSC, no luck.  I have deleted the device and had windows reinstall the drivers.  I have downloaded the sansa updater and it says it updated the firmware to V01.02.18A.

I have run out of ideas to try and unfortunately, patience.  Any suggestions?

Although you will have to re-load everything (files) after, you might try formatting it. That will sometimes resolve inexplicable issues.

I suppose that is my final option, was hoping to not have to do so, but if I must, I must.

Thank you

crazy… tried a different USB port and had no issues (USB mode was MTP).

Either way, I was able to load more songs, so I am good.  Have to remember to use slot #2