Sansa Clip - May have bitten the Dust (???)

I think that my wife (or my kid) left our Sansa Clip on, and it may have self discharged to a point where it’s damaged the battery. The reason I say this is that it when I connected it to charge, it will come on like normal and say “connected” and all, but the battery icon shows as completely full, but it is not holding a charge.

I’ve had it connected now for several hours, with no change in this. If I remove the cable, it says “Battery Low” then turns itself off. Anybody have a clue what’s going on? Is the battery shot or something? 

Any help is appreciated. 

Same here … 

Mine is only 2 weeks old… HELP PLEASE!!!


The Clip will not charge if it’s having troubles communicating.

One can check this status by opening Windows Explorer: Go to My Computer, and look if the device is showing up.

An alternative is to connect, and use Device Manager to look for wee yellow trouble triangles for anything on the USB bus.

The simplest trick is to try different ports on the PC, or force an MSC connection by switching the power switch to LOCK (orange bar showing). and hole the center button in while connecting.  Hold the button down until the device shows up in Windows Explorer (My Computer).  In this mode, the device should connect, and then watch for the happy strobing/rolling battery icon.

Once it’s charging, let it charge completely.

The Clip is under one year old, and is covered under warranty.  If the above does not help, call 1-800-SANDISK, and the support staff can help you out, and also arrange for a replacement unit, if that’s the finding.  You’ll find that SanDisk support is excellent.

Bob  :smileyvery-happy:

Many thanks - it was indeed a communications issue. I have a docking station for my laptop which I had this specific USB cable attached to.  I simply switched the cable to go right into the laptop, and all is well.    -Ed

Hi Bob, Thanks for replying…  

My Clip is the 4Gb version and it is new… as I said like 2 weeks old from Circuit City. 


The Computer has no problems recognizing it. I can see it in Windows Explorer, even Sansa Updater can see it. 

Capacity: 4.0 GB

Version: 1.01.29

Region: America 

You can also see it has the latest Firmware running.When I plug it in the computer, it turn on… you can see the battery icon changing and it reads Connected. But once you unplug the USB cable it just die. :cry:

Note: I tried two different computer and same result.

Message Edited by dishmega on 06-02-2008 09:11 AM

Dishmega - you may want to post your problem as a new topic so it will get noticed. It sounds like it’s different than mine, and your question may not get noticed as much if it’s buried in this post. Just a suggestion.

Return it.  It should not just die upon disconnecting from the computer after charging.  I am assuming you have charged it for at least 3 hours.  You can try a reset by holding the power button up for 15 seconds and see if this helps.

Go Sansa!