Sansa Clip is connected, working, but not charging or being recognized on different computers

Hi there,

I have a problem with my newly bought Sansa Clip (8 GB):

Initially it was no problem connecting it to my computer and fully charging it.

Now as it was empty I wanted to recharge it, which actually seemed to work fine, but as soon as I unplugged it, it said

that the battery was only 15% charged (it was connected for several hours).
So I replugged it in my computer, everything seemed to work fine again and, as I was not at home, I let the computer shut down automatically after 4 hours.

Now I’m having trouble that:

a) the battery still gives me only 71%
b) when i connect it to my PC it say “connected” but I can’t find the device on “My Computer” anymore
c) Battery sign is not full but it doesn’t blink as it usually does when it is being charged

I’m using a Windows 2000 SP4-computer at home, the Clip is in MSC-mode (however I also tried to force it by pushing the center button when connecting), I haven’t changed anything about the other usb-connected devices and have tried all my usb-ports.

I’ve also tried it on a Win XP-computer, but here I find the same problem (whatever usb-mode I chose…)…

I’ve reset and formatted the device, didn’t help.

As the display states that it is being connected and as it actually is still working I don’t think that it would be a problem caused by a malfunctioning usb-cable or the more common error with the the broken internal battery connection.

Does anyone have any idea on what to do?

Use the player, and let the battery gauge get down to 20-25% then charge it again. In another charge cycle or two the battery will probably charge to the 95-100% region.

See if the run time corresponds to the battery indication. You should get around 14 hours of playback.

“when i connect it to my PC it say “connected” but I can’t find the device on “My Computer” anymore”

 In MSC mode it will be listed as a drive on the system, and not as the device.

Let me start by thanking for your replys.

a) Eventually I will have to test with a lower battery level of course and see whether it starts to charge then, I had something in mind like that…battery won’t charge up to 100% during the first charging procedures, however I’m more worried about it not being recognized

b) I know that it is being displayed as a drive, not as a device, in MSC mode, so it is not due to that (I would not use it in MTP-mode anyways, as I like it much better as MSC…)

So any more ideas?

I have tried differend USB-cords now aswell, so this does not seem to be the cause of the problem…

Message Edited by friteuseur on 08-20-2009 12:39 PM