Sansa Clip Frozen

I know a lot of people have asked about a frozen Sansa Clip. I used mine yesterday. In the middle of using it it turned off and I cannot get it to do anything now. The batter was about 3/4 charged when it turned off. When I plug it into my computer the computer does recognize it. I’ve tried to reset many times and absolutely nothing happens.

Any suggestions? It’s only about 7 months old so I sure hope it’s not the battery.

when that happened with my Zen Stone, I just plugged it in to the computer charger (made sure the computer was in the middle of a print routine so it would not shut itself down) and left it for 2 days. it mysteriously fixed itself…   I had tried it for 5 and 6 hours, and nothing - it took the 2 day run to bring it back to life…  maybe it won’t work here, but could give it a try…??

You also can try forcing an MSC connection:  turn the Clip off and put the left-side switch into hold; and then hold the center button down as you connect the Clip to your computer.