Sansa clip freezes / dead


I got a Sansa clip a little less than 2yrs. ago and lately it stopped woking, it just didn’t turn on it was totally dead, so I forced msc mode by putting it on hold and pushing the select button while connecting it to the PC and charged it for 24hr. after 24hr. I turned it on by sorft reset ( holding it for 20 sec. etc.) and whoa it turned on so I format close it and plug it in to the PC to charge later I disconnct it and it displays “disconnected” and stays frozen I force it to shut down and I try turning it on but it stays dead?

How can I fix it?



Mine’s a clip+, which I have just had for 4 days.  I’ve only played music on it one of those 4 days…after 7 hours, I experienced It’s “death”.  I hope you get an answer that will work for me.  Good luck.

Just found this info …here’s what worked on the clip+:

@iamterrie wrote:

Just found this info …here’s what worked on the clip+:

You didn’t read the post directly above your 1st one and see the reset mentioned? Just because it didn’t work for that person, doesn’t mean you shouldn’t try it. :wink:

I agree you with you. You will know it if you try…

It could also benefit matters to reapply the latest firmware (see the firmware upgrade sticky thread at the top of the forum)–firmware could become corrupted over time.