Another clip won't turn on

My story is a bit more dramatic then most. My sansa is pretty old. A good year and 2 months. A year ago it went through the wash. I thought it was fine. I used it but then it short circuited. I was devastated. About 8 months later I toyed around with it again and it turned on! I was so happy. That lasted for about 3 days and then it stopped working. About a week ago I got it to work again, but it wouldn’t read on my computer. I found that putting it on hold and pressing the center connected it. Now it won’t turn on. I’ve tried plugging it into the computer and letting it charge. No luck. I’ve tried holding up the power button and pressing all the different buttons. Right now it’s in the freezer. Help?

  Holy cow! Are you kidding? It’s been re-incarnated all these times and you still won’t let it die in peace?

The freezer? Maybe you should wrap it in bacon and throw it on a hot grill.

Seriously though, the old Clips are known for their weak battery connections; maybe one finally let go. You got nothin’ to lose; open’er up and have a look-see. You can probably re-solder it if it’s come loose.