Sansa Clip frozen on startup screen - can't reset, can't update firmware

Hey folks
After a friend of mine connected my Sansa clip to a Mac, pulled out the thing and inserted it again before my mp3 player had the chance to “update database” (or whatever it says), the thing has not been working. I start it up, but it stays on the “SanDisk Sansa” startup screen. I’ve tried holding the power button up for 20 secs, and i’ve tried to install the sansa updater, but the problem is that my pc doesn’t recognise the mp3 player anymore so when I try to open the updater there is nothing to update. 
I’m out of ideas.

Also, on the startup screen there is a little blue pixel next to the k that I’m not sure was originally there… weird.

Hope any of you have some clues as to what might help. 

What happens when you try the reset?  You might try holding the button up longer, 30 seconds or even a minute or longer.

Well, it just turns on (or off if I had already turned it on before attempting the reset). It makes no difference. To reset it, I’m just pushing the button on the left side upwards like when I turn it on, right? I’ve tried that many times now, but it does nothing :S Just did it for a minute. 

Yep, that’s the procedure, holding it up.  I’ve read some people write about doing it in combination with one of the front keys (the left button or the home button, or the center button?), or in sequence with the other button.  Sorry that I don’t recall more (and those experiences might have just been a coincidence–I’ve never been sure).  You might try playing some and see if it has any result.   Sorry!

I’ve tried a bit of that now, but it doesn’t seem to work. Guess it is goodbye mp3 player :frowning:
Thanks for the tips though.

The only other thought:  leave the player on until it runs out of battery power, and then plug it in to recharge–perhaps this will knock the player out of its stall?  But I’m totally guessing here–can’t think of anything else to try.  Perhaps others will have some ideas. 

You don’t need the updater, and it just makes the install more complicated. 

Go to the firmware thread and look for the manual installation instructions—basically, download the firmware, unzip it and copy it onto the Clip’s driveletter. 

If you’re having trouble connecting, put the USB in the computer, open Windows explorer,  hold down one of the direction buttons–>> or the center button–and plug the connector into the Clip. 

Yeah, the main problem is that my pc doesn’t connect to the clip. I tried your method, but… opening a windows explorer browser? What is that going to help? Do you mean the internet browser? I might have done something wrong though. Could you rephrase the method in a very step-by-step way? 

Run disk utility and reformat the disk with the Mac and then move the firmware back to the clip.  You will lose everything but the clip might work again.

@godzilla wrote:

Run disk utility and reformat the disk with the Mac and then move the firmware back to the clip.  You will lose everything but the clip might work again.

But the original poster can’t connect up to the computer to begin with . . . .

The disk? Do you mean the Sansa clip? And how do I reformat it? Sorry, I’m pretty terrible with computers, so if you could elaborate on a dumber level, that would be much appreciated :slight_smile: But when you say firmware, I assume you mean the file from the manual update thread, right?

yes, I am having the same problem.  it was working, then locked up, reset about 10 times, finally came back for one training session, then during my session it locked up and said refreshing media, now it is stuck on the login (clover) screen.  

I am using Media Monkey to setup a playlist, not sure if that is causing the problem.  some kind of corruption, but again, since I can’t get the PC to recognize it, I can’t even reformat.  

Also, i have a micro sd card.  I removed that to hope i can reformat, but still locked up.    This is not the only time OR SanDisk MP3 player that I have had this problem with.     

The only Sandisk mp3 player that I have that still hasn’t crashed is my old original 4 year clip, all the new ones have bombed.  ugh!!!   

I have tried reset several for a minute or more and it is still frozen. That used to work.  It appears to happen when it has been on the charger for a long time. I let it discharge and I can recover it.

Is it possible that the charger is the problem? How about charging it from the computer USB?

I have the same problem, with my sansa clip+. It is quite old,  bought it at least 3 years ago, so maybe thats the problem and it is completely dead and cannot be repaired. 
So, when I was turning on the device, I accidentally removed the micro SD card, and since then it is stuck on the flower logo. Resetting, holding down the power button turns it off, but when I turn it on again, nothing changes. Still stuck at the logo. I tried this several times. Connecting to a PC also does nothing, the PC does not see the device, connecting it to the PC while holding “select” button or any other - also nothing (some people suggested that in other topics).
Is there any possibility to make it work? Any other methods? Or it is broken completely?

Just to be clear: Try connecting with:

  1. Windows Explorer (Computer or My Computer) onscreen

  2. USB plugged into a computer port

  3. The unit powered OFF and holding down the << button (not Select).

Then connect to the unit.

It is possible it’s dead, but this is worth a try.