Sansa Clip+ 8Gb won't get dected

Hi everybody.

My new Sansa Clip+ 8Gb won’t get dected by my pc.
The player didn’t even charge with the provided usb cable. I bought a new one wich fixed the problem, but it’s still not communicating with my PC at all. I tried msc, mtp and auto detection mode, connected it with center button pressed to force msc but nothing happens. Even Windows Media Player 12 does not detect it. I formated the player twice (internal) and tried resetting it several times. It doesn’t work with any of my ten usb ports.

I really don’t know what to do anymore. :confused:

Firmware: V01.01.05F
OS: Windows 7 Pro x64

Regards.

make sure u push the usb cable all the way in thats the mistake i did when i first got my clip

orly?

Next time tell me to start the computer before trying to sync. -.-

I would telephone SanDisk Customer Service about this–you might need a warranty replacement (which SanDisk is good about).  In the U.S.:  1-866-SANDISK (726-3475).  And other SanDisk contact information:  http://www.sandisk.com/sandisk-support/contact-us.