Sansa Clip + 8Gb frozen in a weird way

Hi, my clip is full to about 74Mb, I’ve got my entire collection on there, stuff I haven’t got elsewhere.

It’s frozen, but in a bizarre way.
I’d finished loading a new song onto it, disconnected it from my XP PC, and it froze and didn’t wake up. I had to force it off using the power button. But when I switched it on again, it again got no further past the flower. I repeated this with no further success.

If I connected it to the PC, it would take a good two minutes before it would register, and then showed itself as ‘connected’ as usual, and the PC recognised it. Checking ‘properties’ of the player also showed it still only had 74Mb free. But when I opened the player icon, there was nothing on the internal memory. It just showed the ‘Dev Icon’ icon, and nothing more.

I had a (genuine Samsung) SD card in it right from the start, (2Gb) but I always seemed to have problems with it recognising anything on it, so it just stayed empty. After looking on these forums, I tried taking that out. When I did so, the player closed and started much more quickly, but still didn’t show anything other than ‘Dev Icon’ in the internal memory.

When I disconnected from the PC, it opened up at last, and showed all the folders, but all were empty. If I went to ‘play all’ it showed 1866 songs, but wouldn’t actually allow me to press play.

And that’s as far as I’ve gotten so far. I’m confused - clearly, everything is still on there, but I can’t access it at all.



I wonder if the player is “too full” for it to operate correctly. In that case, a solution could be reformatting the player via Windows (or from the player’s own Settings menu, if you can get there)–of course, you will lose your content on the player this way.

Thanks - I wondered if that might be the case, though to be honest, it’s operated fine for the last year or more on 10Mb (sometimes less) free space.

I really want to avoid losing the content if at all possible.

Is there anything else you think might work, instead of formatting?

This is the same behavior for laptops. I can remember that my hard drive has 100MBish left then if failed. I had to reload the OS too.

if you use MTP mode, it requires more free or “head” space to operate than MSC mode. I always use MSC and also have had less than 10mb (in fact, sometimes kb) free on the player and also the card.

I remember one time I was trying to help someone here and was attempting to duplicate his problem that required me to use MTP mode. All of a sudden, I got the dreaded “Not enough space for Music DB. Please free 90MB” error msg.

End result, I formatted the player (which erased everything), reset to MSC mode and re-loaded the player.

This really is one of those sad situations that the player automatically should prevent–i.e., when the memory gets close to a “danger” level, it sgould prevent further memory space from being used and the player from entering the danger level, with an appropriate and informative pop-up message.

Thanks everyone - I tried reformatting it - several times, but sadly it won’t delete anything. Well it does, in now all the files are officially empty, but it still says it has only 74Mb free, and I can’t load any more on to it than that.

Any more ideas?

Thanks for all your help so far

Can you tell us exactly how you formatted it?

Reformatting should free up all the space from your user content and make that space available. . . .

Yeah - I basically used the format option when the layer was on - via settings, the ‘format’, clicked ‘yes’ and it produced the little flower for ten seconds, and then back to home screen. But everything was still there in the memory, just not there if you try and find it in the files.

Most bizarre.

Since then, using that 74Mb remaining, I tried loading up a couple of podcasts. Listened to them, deleted them, loaded the player on the PC again and all of a sudden I had 93Mb. Repeated the procedure, then ended up with 109Mb. And again, and we’re up to 122 Mb. And on and on. I’m now up to 415Mb, but this can’t keep going on - this freeing up of space started to diminish and seems to have stablised for now. Obviously, a long way below what I should have available.

So, that’s where we are at the moment. Proper melon scratcher, no?

Why don’t you try formatting with Windows, then following up with a self-format from the player itself?

Didn’t realise that would work - so it wouldn’t delete all the files/folders structure? i.e. there would actually be something left at the end of it such that there would still be a ‘settings’ folder to find in there?

Someone else had said that doing that would simply leave you with nothing more than a pen drive. Not sure if they were the voice of authority, don’t remember where I saw it on this forum.

Whn you format via the player’s Settings, it erases the user content but not the player’s firmware and system structure/set-up.  And note that you always can reapply the player’s firmware–see the firmware update sticky thread at the top of this forum. 

Success! Thanks guys :smileyvery-happy: