Sansa Clip + 8GB FM Radio Stopped Working

I bought this MP3 player in October.  I treat my stuff very gently and now the FM radio doesn’t play.  I have tried different ear phones.  I tried plugging it into my car AUX plug…nothing.  I tried using the Record feature to record whatever was playing on the FM station and was able to play that segment back.  I can hear everything else except FM Radio.  ANy suggestions?

I can’t imagine that it would help, but did you try a system reset?  Hold the on button down for 15-20 seconds or more. 

Thanks for that very helpful info!!  I was feeling  very irritated that my sansa clip had stopped working right in the middle of a song when I had just purchased it less than 6 months ago. I had tried holding down all the various buttons in my desperation, but apparently it was not long enough. Once I held down the on/off button for the time you suggested, my music came alive again. Yippee!!!  I thought  I was going  to have to purchase a new battery for it already, or even worse buy another 8 GB sansa clip because I really loved it.

Coincidentally, the same thing–fm radio stopping working–also just happened to me, for the first time, a few weeks ago.  The reset did the trick for me as well.   :slight_smile:

jojnjack35, is your fm radio in pause?  Press the top (12 o’clock) button to play/“pause” the fm radio.