Sansa and Timex clock radio no longer play together nicely

I had posted this as a reply to a message about the clock radio, but now that I think of it I don’t know what attention it will or won’t get there, as the original post was not a question, just information about the clock radio.  So I’m putting it here as well with its own subject.  I’m really frustrated about this.  I’m tempted to just buy a new clock radio and a new Sansa as the simplest solution, and resolve to never do what I describe below again, but I am not made of money, unfortunately…!

Sansa stopped responding to clock radio’s remote and does not play through the clock radio’s speakers.

This is the clock radio:

http://www.amazon.com/Clock-Radio-with-Sansa-Dock/dp/B00108UG6E/ref=sr_1_2?ie=UTF8&s=home-garden&qid=1241619172&sr=8-2

This happened after I downloaded three mp3’s from Amazon to replace ripped tracks that were bad on the CD’s I ripped. Also ripped a new CD and, in addition to putting its folder on the Sansa, copied one of its tracks into an anthology where that track was bad. All files were renamed to match the names of the ones I was replacing. They were not exactly the same size in any case. One at least was significantly larger than the one I was replacing. Don’t know if this matters to the Sansa or not.  Also the only tracks that had been run through Windows Media Player were the tracks from the CD I ripped.

After the initial symptoms, I carefully connected to the computer, disconnected properly, and allowed the Sansa to resync, thinking this might be the source of the problem. After that it worked for a while but ceased to work again later. At one point I saw a message saying something about Rhapsody having to be re-enabled. I have never knowingly *had* Rhapsody enabled - I’ve never put anything on the Sansa, until yesterday, that I had not ripped myself.

I had thought Amazon’s downloads were not copy-protected? (I don’t even know that that’s the source of the problem - it’s just the only thing that’s changed since the Sansa worked.)

I’m assuming (hoping) that I can fix this using some combination of resetting, reformatting, recopying songs (fortunately I have a backup of exactly what’s on the Sansa), but I was hoping someone might be able to shed some light on *why* (!!!) and perhaps suggest a less drastic fix.

I don’t know if it works with earbuds or not at this point - I have to locate them, as I use the Sansa almost entirely on the clock radio. (Edited to add that I found the earbuds and it does work with them.)

TIA!

Hmmmm… Something else I’ve also never done is copy songs that hadn’t been ripped with Windows Media Player - I just copied the three I downloaded directly to the Sansa without letting WMP recognize them. I don’t think much about details like that, as before yesterday all I had on the Sansa was the CD tracks I’d ripped with WMP.

Any thoughts as to the source of the problem welcome - I’m pretty sure I can fix it OK, I’m just curious as to the source, and especially that fleeting message about Rhapsody.

OK, so far I take it back about being able to fix it.  I have tried a hard reset (holding power button 20 seconds).  I have tried reformatting and recopying the music over, *after* having WMP recognize it.  The only other thing I can think of is updating the firmware, but WHY?? (Since it worked fine with the current firmware until a couple of days ago.)

I even unplugged the clock and took out the backup batteries, in case it was on the clock side instead of the Sansa side.  No joy.

Argh.

Adding that at one point it refused to connect to the computer as a regular USB device (lock + left arrow button, per tech support when I first bought the thing).  Would only connect in MTP mode.  I’m assuming that had something to do with the Rhapsody thing, which I’m in turn assuming had something to do with the mp3’s from Amazon.  I vaguely remember setting up something about Rhapsody when I bought the thing, and that I didn’t want anything to do with it.  And I could be all wet about everything…  ;->

The hard reset fixed the above problem.  I just mention it in case it might shed some light on how to fix my main problem, that it no longer works with the clock radio.

Adding that it is V2 and the firmware version is 11a.  I have gotten the 16a update, and I guess I’ll try it, but it *did* work fine with the version it came with…!

You really need to update that firmware, regardless of whether it helps with your problem or not. You still have the original firmware that came with the v2 models that didn’t have the USB mode switch in the SETTINGS menu. You’ll have to force MSC mode (as there’s no way to select it on the player) in order to update.

Follow the MSC mode instructions for manually installing the f/w update in the firmware post here. By updating, you’ll also get some nice enhancements and bug fixes.

I’m going to, I guess.  I just hope it does not then stop working altogether.  My experience with changing anything on anything computer-controlled is that around one time out of four or five what you do to “fix” or “update” it breaks it or breaks it further.  I’m not pulling these numbers out of my hat - this is my actual experience.  To me, “changing anything on anything computer-related” translates to “be prepared for the possibility of subsequently spending massive amounts of time, money, or both.”  So I try to leave things alone as much as possible.  Wish I’d left those bad tracks alone…

Just like Planck’s Constant, the atomic mass of rubidium, and whether hot dog buns will ever be available in multiples of wiener counts, you can bet that firmware 03.01.16 is as stable as can be for the v2.

Oh, and the Timex dock was a feature update, at least in the v1 updates, and I’ll bet this jar of Cheez Whiz on it, the v2 will benefit from the update.  Oh, and you’ll get a handy new feature!  You’ll have a selectable USB mode.  The ‘11’ firmware didn’t offer the option, being the original installed version.

Update that puppy!  You’ll be glad you did.

Bob  :smileyvery-happy:

I did update it, no problems, the selectable USB mode is nice, it works fine standalone (never was broken standalone), and STILL will not play nicely with the clock radio.  Does not play through the speakers, does not respond to the remote.

Can anyone tell me how to completely take the thing back to square one?  I’m assuming that a) that would fix my problem and b) I have not yet accomplished this in spite of hard reset w/ power button, using the menu to reset, and reformatting and recopying the songs over.

Unless I *did* accomplish that, but it’s still detecting the Amazon tracks as something it thinks I’m not supposed to have - I just realized I did not take them out of my backup.  (I’m working on the assumption it thinks they are not something I’m supposed to have based on that Rhapsody message that went by when I plugged it in the clock radio.  But why it should care when it’s connected to the clock radio and not when it’s stand-alone I do not know.  The whole episode is puzzling and annoying.  Especially since I cannot use my Sansa for the main purpose I bought it!)

Well, well, perhaps I found some info:

http://forums.sandisk.com/sansa/board/message?board.id=shaker&thread.id=121

Thank you for contacting SanDisk Technical Support.

Please be informed that the player does not support purchased songs. You can only transfer regular mp3 files to the player. These Mp3 files are not licensed.

Should you have any other concern with our products, feel free to contact us again.

Best Regards,

Now, the above *was* with regard to iTunes.  I thought Amazon downloads were indistinguisaable from tracks I had ripped myself, but perhaps not…?  (Never thought I’d have to worry about the technical details of such…  :frowning: )

There are 2 ways of getting music from Amazon (and also Rhapsody). You can purchase MP3 music directly, or you can subscribe to their service(s) that provide slightly higher quality music files in a DRM crippled form.

To make use of the later (DRM’ed) files you would need to “sync” both the music and licenses with the player (which requires connecting in MTP mode). And, you also have to periodically update the licenses on the player in order to continue playing those specific music files. It sounds like you’ve done this at some point even if you may not have intended to.

MP3 files do not have any form of copy protection, so it you have MP3 files they should still continue to play (even if the other DRM’ed ones do not).

I’m not sure if/how this may have any effect on the player working when plugged into the Timex clock though.

If you really don’t want to ever mess with DRM’ed music and/or subscriptions services, the best way to clean things up would then be to re-format the player and start over with putting only non-DRM crippled music files onto it. Even then, you may still run into problems when connecting to your computer for certain things and may also need to use whatever software that initated things to de-authorize the player so that everything forgets about it.

It’s not *supposed* to be copy protected - I simply bought three tracks from Amazon, copied them to the player in the appropriate places, and renamed them to match the bad tracks I bought them to replace.  I don’t even *know* that’s what caused the problem, but considering that things worked flawlessly until *just* after I put them on the player, and seeing that Rhapsody message go by, I have my suspicions.  I have *never* knowingly had Rhapsody enabled or had anything to do with it - until the current problem occurred, I had just picked stuff from what I had ripped from CD’s myself and copied it over, occasionally adding new stuff that I had also ripped from CD’s myself.

I’m going to take the purchased tracks off, do everything I know of to reset the Sansa (is there anything other than reset from the menu, hard reset with the power button, and reformat and recopy - WITHOUT those purchased files! - the music that I should do?), and try again this evening.

Thanks to everyone for the help - I *am* glad I updated the firmware.

>>use whatever software that initated things to de-authorize the player so that everything forgets about it.

See, that’s the problem - *I* didn’t do anything with regard to any subscription service.  But something apparently thinks I did, at least when it is connected to the clock radio.

Does the reset with the power button work differently/not at all with the updated firmware?  I seem to recall some kind of messages with the old firmware (? or maybe I’m hallucinating?), but with the new firmware it just turns on and then turns off again.  I don’t know if any reset is taking place.

I unplugged and removed the batteries from the clock radio and even the remote, although there’s no way outside of the Twilight Zone that the *remote* could be the problem…!  Left them out for several minutes.

I reformatted and soft reset the Sansa.  Then I took *its* battery out and left it out for several minutes.

Copied a backup of my song files that has never had the offending (I’m assuming) Amazon downloads in it, ever.

Same old, same old.

Did some searching here.  Found what looked like some similar problems with subscription services, fixed by Sansa.fmt.

Then I found this (message 4):

http://forums.sandisk.com/sansa/board/message?board.id=e200&message.id=29468&query.id=341095#M29468

Fortunately!  I was about to try the Sansa.fmt thing, but I see here that’s only v1, and that the only thing I can do that I haven’t done for a v2 is to format in MSC mode through Windows.  (I got the impression somehow, previously, that that was not a good thing to do, but I am becoming desperate.)

Will that (formatting through Windows) do anything I haven’t already done? 

What I want is to get the thing back to the state it was when I bought it (you know, when it worked…), but either I haven’t been able to accomplish that or something is permanently broken…  :frowning:

After formatting your v2 via Windows, you simply optimize the memory by using Settings > Format > Yes.

I wish I had the Timex here to experiment with it, as it looks like a promising little guy.  Not very many cool e200 gadgets out there.  Try the “double” format (Windows then e200 onboard command), load a few songs, and see what happens.

Bob  :cry:

I’ll try that, thanks.

The clock radio is (was) very nice for my purposes.  I’ve seen some complaints that you can’t wake to music from the Sansa, but what I did with it was listen to random tracks a little while at bedtime.  Don’t even know if it has a “sleep” for the Sansa, as I was just turning it off myself. 

My needs are very simple - it plays music, I’m happy…!  ;->  So it takes a lot to make me *un*happy - like it stopped playing music…!  :frowning:

Well, the last resort didn’t work.  The clock radio recognizes the Sansa (or the Sansa recognizes the clock radio) to the extent of turning on if I put it in the dock when it is off.  No sound through the speakers, no response to the remote.  Guess I’ll go back to the trouble ticket I put in, refer them to this thread, and take the battery out so I can get the serial number to give them.  Not a lot of hope on my part, though, unless there’s some kind of reset only a tech can tell me.  At least it still works standalone.

If it turns out I have to buy a whole new mp3-clock radio combination, any recommendations…?  :cry:  (I’m scared to get another Sansa and plug it into the clock radio, or another clock radio and plug the Sansa into it, as I’m afraid I’d just wind up with another semi-dead electronic item - 'cause I don’t know which killed which…!  :angry: )

I found this:

http://forums.sandisk.com/sansa/board/message?board.id=e200&thread.id=26270&view=by_date_ascending&page=1

But it looks like it’s for v1?  It looks like maybe it’s just the format thing that I can’t use on v2?  (Can’t tell exactly from the message, reluctant to try it unless I know it’s OK for v2.)

The e200 series v2 devices boot up with a SanDisk logo with reflection, and a blue sansa logo below that.

The v2 devices have a different processor than the v1.  The v2 processor is the same as in the Fuze and Clip, the Austria Microsystems processor.  This new family of devices uses a firmware binary file, compared to the mi4 format firmware of the earlier machines.

Bob  :smileyvery-happy:

Thanks, Bob.  I appreciate all your help.

I’m going to try just one more time.  I’m going to pull the SD card out and format it separately.  I’m not going to put it back in until I’ve done all the other steps (not that it’s where the offending tracks ever were - I’m just going to do belt and suspenders, one last old college try…).  Then I’m going to format the internal memory via Windows and via the Sansa itself.  Then I’m going to do a reset with the power button.  Then I’m going to take the battery out and put it back in.  Then I’m going to install the firmware *again*.  Then I’m going to do a reset with the power button.  Then I’m going to take the battery out and put it back in.  Then I’m going to format the internal memory via Windows and via the Sansa itself.  Then I’m going to copy over the backup that never had the offending tracks in it, from a *location* that never had a backup with the offending tracks in it.  Then I’m going to unplug the clock radio and take the batteries out and leave them out a *long* time.  I’m going to take the battery out of the remote and leave it out a *long* time, just in case I am in the Twilight Zone. Then I am going to put the batteries back in the clock radio and remote, plug the clock radio in, hold my breath, and plug the Sansa in.

If this does not work, I am *not* going to throw them across the room, as the Sansa still works with the earbuds and the clock radio still works as a clock radio.  I am sure going to *want* to, though.

Well, somebody congratulate me for my self-restraint. The clock radio and the Sansa are still in one piece.

As you may have guessed, after doing my best to take it back to square one, and copying songs so pristine they had a date of last November, long, long before I made my big mistake, they *still* do not play together nicely.  And they still work separately just fine. 

In other words, exactly the same as when I first observed the odd behavior.

Well, I have an open trouble ticket.  I guess I’ll go add this latest piece of information to it, FWIW.  And prepare myself to buy another mp3 player/clock radio combo, probably…