Please god someone help me!!!! Rhapsody/Reformating issue

Last week my Sansa device said “not enough space for music DB. Please free 90 MB”

I thought I would take care of this one myself so I reformated my device like the internet told me to do.

It fixed that problem but now Rhapsody doesn’t recognize it as one of the devices it works with. When I plug it into rhapsody it displays it like a flashdrive. Right clicking on it only gives me the option to go to Device options or _Disconnect _which gets me no where.

I don’t know what to do. I am significantly more depressed not listening to my music. I need your brilliant help!!!

I haven’t used Rhapsody in awhile so I’m rusty but…

open Rhapsody, connect the unit,  go to probably Help, see if there’s Authorize or Reauthorize in there. If you see it, authorize it.

you might want to check out

Or, go to Settings/System Settings/USB and change it to MTP. Connect to the computer. Send one song over to the internal memory. That might reset the internal clock of the Sansa, which fixes a lot of things.  

Also try going to Settings/System Settings/USB Mode and make it MTP. Open Rhapsody. Connect. What happens?

Whoa. rhapsody recognizes it again


riddle me this you brilliant sorcerer, all of the songs on my trusty micro SD card say that they are not synchronized. the last time that happed I just put them all on again. any suggestions ?

OK, you are still in MTP mode, right?

Find an mp3 on your computer. Using Windows Media Player, transfer it over to the Sansa. Disconnect.

That should re-synchronize your computer clock with the Sansa, and with any luck Rhapsody will also then be synchronized.

What’s going on is that Rhapsody transmits hidden codes because it uses DRM (Digital Rights Mess) to make sure unauthorized songs aren’t transferred. They go through parts of Windows Media Player via MTP. If the two clocks between your computer and your Sansa go out of sync, all of a sudden…the hidden codes don’t work.

Let us know if it works. As I said, I haven’t used Rhapsody in a while.

I could only guess he was in MTP mode. I think it wasn’t working for him because he was on MSC mode before this.