Sansa 280 in Recovery Mode, now what?

My Sansa 280 locked up on me, I just get the startup screen that says “SanDisk” fading in and out over and over.  Tried to do the resets, nothing, held the power button for a while to shut if off.  Used the Hold and Record proceedure while connecting to the computer to get into Recover Mode and the computer sees it as 16 MB-Format, with a text file showing:

Version Info: Product Rev.: PP5022AF-05.51-S301-02.24-S301.02.24A-D
Base Code: 05.51-S301-02.24-S301.02.24A-D
ODM Ver.: S301-02.24-S301.02.24A-D
OEM Ver.: S301.02.24A-D
Build Type: -D
Build Date: 2007.12.24
Build Number: (Build 32.10)

I’m not sure which files I should download becaues I’m not sure which 280 I have.

If it has a recovery mode, its an e200v1.  See:

http://www.rockbox.org/wiki/SansaE200Unbrick#Recovery_Mode

Thanks, so which mi4 should I download, there seem to be three choices for the e200 American, or doesn’t it matter?

        1.00.12 2c11dc0b10f1393115c54b17b6278cd2
        1.01.11A 8fbdfa44671e936bb2fffc9e11e8bedb
        1.02.15a e83a74b44accc88f64f1e81039200442

Generally, the higher the number, the newer the firmware. The newest one should have the most features and the fewest bugs.

Thanks, that’s what I figured.  OK, going for it…

Crap.  Did it, looked as if it worked, but after unplugging it just keeps cycling between the SanDisk boot screen and Refresh Database.  I renamed the file to PP5022.mi4 as instructed and copied it to the drive.  Tried it twice.  Maybe I’ll try one of the other files.

OK, the next oldest version, which was already named correctly, seems to have worked.

**bleep**, failed again.  It restarted properly, but didn’t show any of my files.  Plugged it in, it loaded properly, and the files were all there.  I deleted a few, added some new ones, unplugged, and it went back into cycling between boot and refresh.  Maybe when I’m connected after the mi4 reboot I should just format?

Tried it again, didn’t seem to work, plugged it back into the computer, went into refresh mode, which is weird since it normally does that when unplugging it, but it showed up properly in the computer when done, unplugged it, refreshed again, as normal, and now I’m using it!  Don’t know if it’s stable or not but it’s working for now.

Now that you have it working again, you should be able to upgrade back to the newest firmware version. According to your first post, this is the version (01.02.24a) you had to begin with.

Yeah but I’m afraid :dizzy_face:  Now that it’s working I don’t want to mess with it.

@jrp3 wrote:

Yeah but I’m afraid :dizzy_face:  Now that it’s working I don’t want to mess with it.

I would at least update to Version 01.02.18. You’re missing out on bug fixes and enhancements if you stick with the older versions.

I went for the update through the Sansa Updater, seems to be working fine.  Yay.  I’ve had this thing for so long and still love it, wasn’t looking forward to getting something different.

Great! Now I’d recommend un-installing the Updater. There won’t be any more updates for this model, and everytime you plug into your computer it will want to ‘phone home’ looking for one. It can be quite a nag, besides being a resource hog on your computer.

If you ever need to re-install the firmware (which the Updater won’t do, it only updates), you can simply follow the manual installation instructions in the firmware posts here on the forum. It’s quick and easy.

Now, sit back and enjoy some tunes!

Good idea, just dumped the updater.  Thanks.

New York Asian Escort Service (http://www.newyorkescortdirectory.com) ]New York Escort Directory includes letting you to choose your favorite female entertainers, (http://www.newyorkescortdirectory.com) ]New York Asian Escort Directory
 booking appointments and arranging you (http://www.newyorkescortdirectory.com) ]New York Oriental Escort to meet up with our female entertainers. We promise you that you will get the total erotic (http://www.newyorkescortdirectory.com) ]New York Escorts enjoyment from our New York Asian Escorts.

My school day

If I were to fall in love,It would have to be with youYour eyes,
url=[http://www.sacramentoescortsasian.com]Sacramento Escort[/url] your smile,The way you laugh,The things you say and do
Take me to the places, url=[http://www.sacramentoescortsasian.com]Sacramento Escorts[/url] My heart never knew
So, if I were to fall in love,It would have to be with you. url=[http://www.sacramentoescortsasian.com]Sacramento Asian Escort[/url]
Ed Walter,Forgive me for needing you in my life;
Forgive me for enjoying the beauty of your body and soul; url=[http://www.sacramentoescortsasian.com]Sacramento Asian Escorts[/url]
Forgive me for wanting to be with you when I grow old