I'm an idiot - recovery mode. Tried the sansa.fmt folder but doesn't work... Please help!

My buddy gave me his used sansa for a Christmas gift.  I loved it.  They when I was deleting his old songs I deleted the other folders on it as well (photo, recordings, etc.)  basically everything except the music folders.  Now when I turn it on it says “load main image failed.  switch to recovery mode.”  I’ve read through all the forums and tried making the sansa.fmt folder (it formatted) but still doesnt work.  I can’t find the stuff i deleted in the recycle bin.  

Thank you in advance and Happy Holidays.  

It’s Christmas time.  Santa has something cool in his bag, I am sure.  Let’s first verify the version 1 device.

When it started up, did you see just the SanDisk logo with sunburst on the splash screen?  I just want to be sure that your e200 isn’t a Rhapsody Sansa, as this version has different firmware.  The R device has a Rhapsody splash screen after the initial one.

You’ve seen how to connect in Recovery Mode, yes?  Start with the e200 turned OFF.  Slide the HOLD switch to the right (orange showing), and hold the REC button depressed while plugging in to the USB port.  This is the most basic recovery mode method.

Alternately, you can initiate Recovery Mode if the REC button is held, and the menu-power button is tapped too. In either case, Welcome to Recovery Mode  will display.  Incidentally, the acronym MSD on the screen refers to “Mass Storage Device” mode, just like MSC.

A brief word of caution before we go further.  Recovery Mode opens the device’s Reserved partition.  Critical data is stored here.  DO NOT use Windows’ format command when this partition is open, or you will erase this critical data!! Only use the sansa.fmt folder trick to tell the e200 to format itself automatically.

Download and unzip the TWO firmware files for your Sansa e200v1here.  This is version 01.02.24, the final release version.  Simply click on the version desired for your region.  The Sansa Updater link is not what you need.

The two files, after unzipping, are pp5022.mi4 and BL_SD…rom  (mental block on the name at the moment). 

When you connect the e200, and open a Windows Explorer window (My Computer / Computer), you’ll see a new icon, 16MB FORMAT.  Double click on this to open the reserved partition.  Don’t touch the version.txt file in there, and DO NOT ATTEMPT to use the Windows Format command that pops up with a right click, bad juju.

Let’s go Window Happy. Drag the first window down to a convenient size, and the second one with your firmware files can be placed on the desktop.  Now for the magic!  simply drag and drop those two firmware files over into the open window that represents the reserved partition.  Cool huh?  Easier than getting the ratio of rum and eggnog just right.

Now, if there’s a bunch of gobbledegook stored on the device, and you would like to start with a clean slate, you can tell the e200 to format the main partition (where the music, videos, and photos are) automatically.  Right click while in the 16MB FORMAT box, and select New Folder.  RENAME this folder sansa.fmt _ , and the Sansa will follow that command after installing the firmware._


Go to the taskbar at the bottom of the screen, and click on the Safely Remove Hardware or Eject command.  Again, WIndows loves to format devices, it’s Eject that you want, not format!


Unplug, and your e200 will restore!  Slide the HOLD switch back to the left.

Let me know how it goes, as the Bobster does have other tricks in the bag.  This one should do the trick.

Oh, I almost forgot.  You’re not an ■■■■■. 

Bob  :smileyvery-happy:


You are my Santa this year.  I have been so mad at myself over the past couple of days for deleting that but you came through with the best present ever!  I can’t thank you enough.

-No longer an ■■■■■

hey.i’ve made the same mistake with a sansa m200 and now my pc doesn’t recognize it anymore.i can’t even format it.what can i do?

You can also try reinstalling the firmware, here’s the knowledge base page for you.  (This for the m200 series. )

Bob  :smileyvery-happy:

i’ve tried this before.this doesn’t work either.:frowning:

Do you remember which firmware version you have on your m200?  They’re a cool device, I like the simplicity and the display.

If it won’t resurrect, perhaps one of the3 newer machines might just fit the bill, especially the Clip+ , but there are some killer deals on Clips as well.

Bob  :wink:

I tried follow this post, but when I try to unzip the file my computer goes crazy, and windows pops up a bunch of internet problem solving windows. What should I do?

What program are you using to unzip the file?