SanDisk Ultra USB 3.0 16GB


I bought the above SanDisk Ultra USB 3.0 16GB 2 months ago for use with my free to air tv set-top box. It worked fine for 2 moths allowing us to record some tv and then after two months a “low Memory” message came up on the tv screen and within 2 days the USB stopped working. I’m not a tech person so can anyone tell me what happened, can it be fixed, would I be entitled to a new USB from SanDisk? Thanks!

Have you deleted any of the shows you recorded on it?

Thanks for your reply Ed.

Yes we have deleted shows to make sure there was room at all times.

The usb will not work now either in my laptop or the tv set-top box. Something has upset it but I’m at a loss to know what. I’m also wary of simply buying a new usb in case it happens again! Any suggestions? Thanks!

Well the “low Memory” message on the  tv set-top box indicates it was experiencing a problem that could have impacted the USB drive.   How are you deleting the shows?  Are you using the  tv set-top box or the laptop?   When you plug the USB drive into the laptop does Windows indicate an error with it? 

With it plugged into the laptop, determine it’s drive letter then find the Command Prompt option in the Windows menu and RIGHT click on it and choose the Run as Administrator option then in the Command Prompt window enter a CHKDSK command for the drive.  Something like:

chkdsk  F:  /f

where F: is the drive letter of your USB drive.

To return the drive use this link:

Hello Sir/Madam

I have ScanDisk ultra 3.0 Flash drive. I bought it from Amazon online shopping few months back . It has been working good, but suddenly it stopped being recognized by my Windows 10. Kindly kelp me to resolve thi issue.


Have you tried it in a different pc?