SanDisc Cruzer U3 16GiB

Hey guys.

I have this SanDisn 16 GiB for a long time and everything was perfect until 5-6 days ago.

The thing is that i plug in the USB devise,it flashes as it should and when the flash is about to stabilize…it fades out instantly and the 2 parts of the USB that appear in “My Computer” for 2-3 secs disappear.

I tried all the solutions that i found here but nothing…

Can anyone tell me what to do…??

P.S.:Twice i managed to click “Format” and worked because now its not even poping up the formation panel but then it says “Windows cannot format the Card Reader”

sounds like a bad drive

That all you got to say ???
Just a bad drive ?

Why it was working perfectly for more than 5 months. 
So find me a solution,you are a guru aren’t ya ?

You guys know anything so give me the solution.

what you describe is a hardware failure. there is no solution for a hardware failure. it is a bad drive and will need to be replaced. if you are within the warranty period contact sandisk for warranty replacement. 

I’m a newbie to Flash Drives.  I use a MacBook Pro and just bought the Cruzer 16GB Flash Drive.  Here’s my question: What do I do now?

  • Do I need to format it?  If so, how do I do that?

  • Do I set up a password for it?  If so, how do I do that?

  • Once I’ve done formatting and given it a password, etc., can I just drag files, docs, etc. to the drive? 

Looks like the company could put a dinky sheet of paper with some basic instructions for us idiots. 

I told you I’m a newbie… forgive me.  Thanks in advance for any help you can offer. 

you should probably start your own thread since this is a new topic.

anyway here are somehow to videos that will get you started. you can also type in your question on the sandisk knowledgebase for answers to your other questions. 

Thanks, but they’re all for Windows/Vista.  I have a MacBook Pro.  Is there another site for Macs? 

Personally I would plug the stick into the machine and see what windows/messages popup.  They could be from OS X or the U3 Launchpad but you will at least have an idea what needs to be done.  Most new SanDisk devices do not include U3 so it will probably not be an issue for you at all.

I recently purchased a SDCZ36-016G AW11 flashdrive. I receive an unknown drive error when I insert it into a computer running Windows Vista 32- bit and a Laptop running Windows 7 64-bit. What happened to this drive and can it be made useable?

Hi.I’m have now same problem whis my 16GB Sandisk. If you find how fix this problem reply me please.Thanks.