Sandisk Ultra Backup 64Gb not working on PC but ok on TV


I bought an Ultra backup 64Gb a couple of monthes ago and it was working well. But one day it did not anymore.

Now it is working well on my TV but not anymore on any other computer. I can’t format it, I can’t see any files. The only thing I see when it’s on my computer: a drive with a letter (J:) with 0Mb of space and 0Mb of docs.

With the tool USBDeview I can see the key. Here are some details:

Vendor ID 0781

Product ID 5535

Firmware Revision 1.26

Instance ID \VID_0781&PID_5535\20044319901156408B7B

Hope anyone could help.

PS: sorry for my bad english

I suspect the drive’s FAT got screwed up somehow.  Open a Command Prompt window and run CHKDSK for the drive.  See what it says.

Hi Ed, thank you for your reply. I already tried and it does not work.

Just now I have been allowed to see my files in the key but I cannot open or delete them. It temporarily freezed my computer so I removed it. When I reconnect I just have a “removable disk” with a letter but I cannot open it at all.

I’ll try to do something with a Linux liveCD, that’s the only thing I did not try yet.

I thought my key was dead but the strange thing is it’s working well on my TV. I don’t understand how it is possible

PS: chkdsk sais me “cannot open volume for direct access”

It’s most likely the TV is using a Linux system so a Live Linux system may be a very good idea.  I like Porteus myself.

If this was working before, it should be working fine. Were there any modifications made on your PC prior to getting this?

Hi, thanks for your replies.

No modification on my computer. The key is not working on any computer anymore (I tried at least 5 different computers).

I hope to be able to do something with linux livecd. I’ll let you know.

Ok nothing works under Linux.

FDISK /mnt/sdf1/ said me “I don’t know how to handle files with mode 40755. You will not be able to write the partition table.”

MKFS -t ext3 /mnt/sdf1/ said me “Device size reported to be zero. Invalid partition specified blablabla”

I don’t know what to do now but sending the key back for an exchange. But I’ve a lot of personal docs so I can’t. I think I just lost 50€.

@micha30000 wrote:

I don’t know what to do now but sending the key back for an exchange. But I’ve a lot of personal docs so I can’t. I think I just lost 50€.

There have been cases in the past where once confirmed defective, SanDisk has allowed physically destroying the drive prior to returning for security and respect for people’s private and sensitive files. You should probably call them.

OK good to know thank you. I’m speaking by email with Sandisk support and they asked me if I had important data, I said yes and that I needed to securely erase or destroy it. I hope it’ll be possible to do so. Thanks for your help everybody