Sandisk Ultra 32gb, shows up as removable drive but no volume


I am new to this forum and have scoured all over it and the rest of the internet to find a solution but can’t find anything that works.

I have a couple Sandisk Ultra 32gb Ultra drives (Not the back up ones).  They were working fine for the past year or so but recently I can’t get them to show the data on my Vista 64bit PC.

They show as a removable drive and when I click on them they show as empty.  I look at the properties and both the used space and free space is 0.

In the device manager they are showing under Hard Drives.  I have tried changing the letters of the drive (as well as removing the letter) and nothing seems to show the volume.   I seemed to remember they used to show up under my USB controllers before so I am wondering if Vista now things it is a different kind of drive.

There are videos files on the drives and I have confirmed they work because I can still play the USB drives through my BluRay players USB port.

I uninstalled the drive then plugged it back in and Vista found it and then said it installed the driver correctly.  There are no conflicts in the device manager when it is plugged in.

I have used other USB drives (thought the USB port was dead) and 3 other drives (2 other Sandisk and 1 Kingston) both plug in and work perfectly.  It is only the Sandisk Ultra’s that I have the issue with.  The other 2 Sandisk ones are not the Ultra’s.

I tried to copy files to the drive just to check if it was reading incorrect volume but it actually gets a message that the location of  my source files is missing, which is strange because I can move the files to other drives or locations but it only errors when I try and put it on the Ultra with the 0 volume.

I am totally stumped.  Hopefully someone can help out.

I should have just waited a few minutes longer to do a few more searches.

My apologies.

The issues was Samsung Kies.  I stopped the process running in the background and it worked perfectly.

Everything good.

Feel bad posting.

Don’t feel bad. Chances are you have helped someone in the future with the same problem scouring the forum looking for answers/solutions. At least at the present, there is no FAQ or sticky with this information, so the more threads that mention Kies (and other programs) that are causing the issue, the better for everyone.

Thank you for your contribution! :wink:

I stopped the 3 Kies processes and It works. Thank you !

I have this very problem.  but no 3kies ???

the drive is recognized, but comes up 0 free space 0 room left.

it knows its a fat32

it can be mounted with partition software and read as correct size and volume ect

i can see the directory structure, through editors, but not the files themselves.

some coments about mbr is they are not on flash drives and some say they are.

the first sector of this flash drive is

00 00 00 00 00 00 00   00 00 00 00 00 00 00 00

the last sector of 496  is

00 00 00 00 00 00 00   00 00 00 00 00 00 55 AA

so some where in about 16384 is another, maybe copy of the mbr  as it implies fat 32, fat 2 , ect

then another possible mbr code at 19456 (a copy of 16384) looks like a copy

so the data is still there.  i just need to know how to fix the flash drive as xp will be able to read it. 

i do have a win7 machine that may have corrupted it.  or just a power down failure. 

24g used out of 32g.  a lot of info i want back.

thanx in advance.