SanDisk Ultra Fit 32GB USB 3.0 Flash Drive issues

Hello everyone,

I tried searching the forums but couldn’t find anything close to what i am experiencing. I will try to be as thorough as possible. 

I ordered the SanDisk Ultra Fit 32GB USB 3.0 Flash Drive about a month ago, put it in my work laptop (which i use as personal to an extent) (windows 7) and copied over about 10GB of my MP3’s on to it. All USB drives on the computer are 3.0 compatible. I then plugged the drive in my 2017 Equinox and have been listening to music from it no problem. I wanted to add some more music but when i plug it back in to the computer it doesn’t recognize it. Doesn’t show in Disk Management. nothing. The faint red light does pop on though, but no chimes from the computer, no noises. i docked my work computer, tried using the 4 usb 3.0 spots on the dock, and nothing.   I then tried to plug it in to a different Windows computer (windows 7) and it also doesn’t recognize it. I then tried my Mac, and nothing… and it also doesn’t show in disk utility.

strange, right?

So as a last resort i tried plugging it in to my sons computer, which is Windows 10. Plugged it in the 3.0 USB and no noise, but i get a pop up after about 10 seconds saying there was a problem with the drive.Still doesn’t show in Disk Managment though… I thought ok, this is a good start at least. I then plugged the drive in to the non 3.0 drive and VOILA! The drive is recognized. Checked disk management, boom… listed. from there i am able to format, change drive letter, etc. Works perfect. I tried formatting in all formats and then trying it again in the other computers, and it will only read in the non 3.0 drive on my sons pc…

Does anyone have any ideas as to why this is happening? I have no files on my sons computer, and since it’s a school laptop with a SSD of only 32gb i can’t fit my music on it. Any and all help would be greatly appreciated. I contacted Amazon and they are replacing it, but told me to keep this drive. If it can be saved, i will send the other back. if i should cut my losses i will. 


USB 3 has more pins than USB 2. This may be a hardware issue with the extra pins for the 3.0 connection. That could explain why it works on 2.0 but not 3.0. 

So basically in a roundabout way the drive has failed to an extent, and unless i plan on using it via the 2.0, it’s DOA.

I kinda assumed that, and i’m kinda bummed that my work laptop doesn’t have a standard 2.0 drive…

thanks for the info!

Does the Equinox system use USB 2.0 or USB 3.0?  Does the car sit out in the hot sun with the drive plugged in?  Is there smoking in the car when the drive is in use?

Just wondering why/how it worked for a period of time then stopped working on USB 3.0 ports.