Sandisk Ultra Backup 16 GB doesn't work in any other computers but my own

Hi, I’m running windows 7 64 bit and I recently formatted my Sandisk USB from FAT32 to exFAT because I wanted to transfer a particularly large file.

However, now that I’ve done this the USB isn’t recognised by any other machine other than my own. It tells me to format the drive and try again. I’ve tried this and changed it back to FAT32, but no luck on other computers.

This has pretty much made my stick useless.

Any help would be greatly appreciated.



For large files, those bigger than 4GB, and compatibility across multiple systems, use the NTFS format.  It may also help with your current problem.

Hey, Ed.

The problem started when I’d formatted the disk to NTFS. I think I figured it out though. The reformat had deleted a bunch of dmBackup.dll’s, eula.xml and cacert.pem files.

I had a back up of these and put them back on. It’s now recognised by other computers. The little “Installing device drivers” bubble pops up now.

Not sure why this happens but it’s a real probem. Especially if I hadn’t had these files.

Not sure why this happens but it’s a real probem.”

??  What? Formatting a drive and loosing the files on it as a result?  That’s the way the format function has worked since it’s inception 20 yrs ago.  Having a user not know enough to backup files they need on a drive before formating it has been a real problem for 20 yrs also.  :smileyvery-happy:

Although to be fair there is a Windows convert command to convert a FAT drive to a NTFS one that does retain the files on it.