sandisk usb sticks

i’m having a strange problem with usb drives - can anyone help?

i have a 16GB sandisk and when i copy media files (music/video) onto it from files already copied/converted to my windows7 laptop, they play fine from the stick on the laptop, (and also on linux and android machines.)

i just bought a new 32GB sandisk, and when i copy those same files to it in exactly the same way, they won’t play at all, not on the W7 laptop, nor the linux or android.

as a matter of interest i also have a toshiba 64GB stick bought recently and files copied to that won’t play either.

i have an older usb stick (over 5years old) which is only 185mb capacity, but the same files copied to that one play on all machines too. But this stick is too small for all my files.

any suggestions as to why files won’t play on the 32GB & 64GB sticks?  Is FAT32 formatted differently on the larger disks & is that the problem?

PLay with the file format. Make sure it’s exactly the same as with your old 16GB one. Either, it might be FAT32 or NTFS.

I believe the cluster size changes as the drive size increases for both FAT32 and NTFS.  Maybe that is having an impact?  What are you using to copy the ripped files and what are you using to play them?

i have tried  all the formats, first the original (FAT32 i believe) then reformatting to  FAT32, exFAT & NTFS.

i get the same result. I convert the file to MP4 onto my laptop - WMP & VLC can play it.

i copy it (copy/paste in W7) to the 32GB sandisk  then try to play it from there (using my laptop). WMP says the file is damaged or incomplete. VLC just hangs.

I copy/paste it to the 16GB in exactly the same way, WMP & VLC can play it from the sandisk. So can VLC on linux and android.

i’m aware there are size restrictions on what you can format to FAT32 - up to 16GB in W7, and i wonder if the formatting for disks bigger than that is different, and somehow problematical. (btw these vids don’t exceed 4GB, the FAT32 file restriction)

Just to confuse things further, some videos, converted and copied in exactly the same way,  will play from the 32GB stick.

i bought this stick off EBAY (UK seller… not from Hong Kong!) - i’m just wondering if it’s a fake… a few years ago i bought a flash drive from EBAY that did turn out to be a fake, a very good one… looked like all my files had copied to it, then when i tried to open them some months later the disk wouldn’t function. I contacted the manufacurer and after giving them some info they told me it was a fake, but of course by then the seller had long gone…

After you do a copy & paste to the 32GB sandisk do a Windows Safely Remove function to the drive.  Then reinsert it.  Does that help?

yes - tried that, still doesn’t work - just says windows cannot play the file…

I’m out of ideas.  Sorry.

yesterday i bought a 16GB sandisk from PC world - it works perfectly with all the videos that didn’t work on the 32GB sandisk or the toshiba 64GB stick.

i bought the last 2 from supposedly reputable EBAY dealers - i am beginning to suspect they might be fakes…

If you’re suspicious of the drives being genuine, you can test them with h2testw.

Thanks for the update beccles.  If you ever get a new 32 or 64GB flash drive let us know how it works for you.

Nice link Tapeworm.  Will the app check for the read only problem?

@ed_p wrote:


Nice link Tapeworm.  Will the app check for the read only problem?

I have not had the occasion to use it myself, but I know of several people who have discovered fake, or counterfeit memory cards and/or flash drives with it. If it only measures 2GB and the drive is supposed to be 16 or 32GB, you know you’ve got a problem. :wink: