Sandisk ultra 32Gb: No media

Hi all,

I use a PC with Windows 7.

I just bought a brand new Sandisk ultra 32Gb. I started to transfer files on it by using SecureAcces.

I went to eat and when i came back i could not use SecureAcces anymore since the login button was grayed. 

So i unplugged my usb key then plugged it again.

Now it doesn’t appear in Windows explorer.

It appears in Windows disk management but it says “No media”

Is there a way to fix that ?


So i unplugged my usb key then plugged it again.

Did you use the Windows USB Safe Remove button?

Is there a way to fix that ?

With the USB key removed, reboot. Then replug the USB key.  And if it is seen by Windows, before loading anymore stuff on it, run a CHKDSK command on it. 

No I didn’t use the USB Safe Remove button because it had disappeared, just as if the key was already removed.

So i rebooted, replugged the key, but i it still doesn’t appear in Windows.

I tried to repair it using diskpart. Here’s the message i get :

DISKPART\> clean Virtual Disk Service error: There is no media in the device.


Hopefully there were a few more commands before that one.  Such as:


 list disk                                                                   

select disk 1     * Note: disk nbr is the nbr of the USB disk               


Hi squid, any luck onto this one yet?

I am having the same problem with a SanDisk 32 gig usb stick (cruzer fit) - it worked for a while and now it does not work now.  I went through all the steps listed above as well. While using DISKPART this is what I got from the “Clean” command:

"Virtual Disk Service error:

There is no media in the device."

I’d love to make it work or get another one…

  or get another one…

      Same happened to mine. It was almost completely full then everything on it disappeared during a file transfer. I turned on every windows service that could effect it but nothing would work. I took it from my usb 3.0 slot and inserted it in a usb 2.0 one and it actually read it but some files were locked or something. I also found on one of my free download sites a file unlock utility made by iorbit. Your files are there just keep messing around with it til you find them. Options are to try and back it up, complete copy, defrag can help(if it lets you) uninstal/reinstal driver, or any utility program that can help. Between advanced system care(iorbit), ccleaner, and glarys utilitys there is not many programs I need.

Between advanced system care(iorbit),

Are you referring to the 30 day free trial version or the $29.95 version??  The similar Slimware Utilities Slimcleaner Free is rated better by and is completely free.