SanDisk Ultra 32GB MicroSD HC I show as 31MB?


My SanDisk Ultra 32GB MicroSD HC I show as 31MB and sometimes refuse to be recognized. 

It was pulled from my Sony Android phone. 

Any idea how to repair it?

There’s no hidden partition. 

Also tried to use FbinstTool to force format it and doesn’t help. 



If there is no important data, try to reformat again using command prompt.

If it is still not working, I would recommend to re-partition the drive. 

1.Right click on Computer

2.Select Manage>>Storage>Disk Management.

3.Find your drive. If it shows “Unallocated Space”, right click and select “New Simple Volume” and create a new partition.

Check this discussion :

Incase you have important data in your MicroSD, still format the SD card and use a recovery software to retrieve them.

You can try Recuva which is free software. Since it is a free software it may not dig deep to recover files like others paid software.

I suggest you to purchase paid software only if the files are listed in preview option of trial version. Software that I have used and can recommend are: or

You can ask for a replacement, my guess is the card is corrupted. I have used many recovery tools due to such issues in my card and none seem to work. There are only a few good ones like Stellar Photo Recovery and others that will be your best shot for recovery,