[Q] SanDisk Ultra 32GB MicroSD HC I - Now says it is 30 MB !!??

I have a [/SanDisk Ultra 32 GB microSD HC-I card that I use in my Transformer Infinity tablet as a storage device. I had it setup as (1) 32 Gig FAT32 partition.  Well I messed around with the partition on it the other day and it no longer would work. I decided to just wipe the stick and create a new 32 GB FAT32 Partition.

The thing is, now all (partition) tools I have used says it is only a 30 MB stick and in a “RAW” format !!???

I have tried:

Windows 7 (64bit) Drive Manager and get this this result:

C:\Users\John\>chkdsk /X /F S: The type of the file system is RAW. CHKDSK is not available for RAW drives.


Mini Tool Partition Wizard with this result:


Easues Partition Wizard Shows this:


I know the sectors must be messed up. I have tried a Low Level Format but it just tells me that 30MB is to small to Low Level Format.   What can I do to make the 32 Gig micro stick show up as 32 Gig (fat32) not 30 MB ??

Please help if you can… I will try anything. I do not have Linux installed, but supose I could if needed.

Thanks !!!