SanDisk Extreme 32GB UHS-I/U3 only shows 30mb and wont format

Hello all, I bought this card from amazon a wile in preporation for a new cell phone:

http://www.amazon.com/gp/product/B00M55BS8G/ref=oh_aui_detailpage_o04_s00?ie=UTF8&psc=1

But when I finaly got an lg g3 I put it in and the sd error icon would flash and would not format.
I tried using the adaptor and plugged it into my pc and it came up as a 31mb device with a raw format and no free space

amazon diskmgnt diskpart

I think its too late to return it to amazon so I was wondering if there is a fix for this. I’ve tried GParted (on linux), DiskMGNT and DiskPart. As well as SDFormatter tool v4 with no luck

Thanks in advance for any help

Hello,

In this case the card seems to be defective and needs to be replaced with a new one. you can replace it with the place of purchase or contact sandisk support for it.

Seems like a common occurance with their cards. Multiple 6 page threads, I have the same problem as well, no solutions given that I’ve seen.

Hello,

You cannot state that its a common issue if you see 6 threads with the same issue because u have to think that sandisk sells million of cards and like other electronic devices the cards may fail with a similar issue but that does not mean that its a common error.