Micro SD New out of the box will not format

So I just left Bestbuy with a new SanDisk - Extreme PLUS 64GB microSDXC UHS-I Memory Card

I get home and put the card in my phantom drone and try to format it.  It says it is an invalid format and will not accept the card.  I pop in in the windows 10 computer and try to format it.  negative.  says it isn’t readable and only shows its capacity of 30mb.  Thinking it was a card issue, I pop in the 32 gb card.  same issue.  I took it to another computer and I got the same error.  I have dome all the tricks in the disk management tool.  I have gone to the cmd line and did diskpart etc.  cleaned the card.  Tried to format the partition but I get an error saying a RAW format file cannot be formated.  why is this happening?  why can’t I access this card?  I have tried to use the ErasUS tool to no avail. it says it cannot access either of my cards.  I find it hard to believe I have 2 cards with the same error. Especially because 1 card is new in package. 

any help is appreciated.